locked
Crystal Report Deployment Issue RRS feed

  • Question

  • User-2095978785 posted

    Hi,

    I am using Crystal Reports version 12.0.2000.0 for Visual Studio 2008

    I have deployed crystal reports in production server, but we are not able generate reports.

    It is working fine in my local machine.

    Local machine environment:
    Windows 7 and IIS 7.5 (64bit)

    Production Environment:
    Windows Server 2003 IIS 6.0 (64bit)
    In production we have only dot net framework.

    We also installed crystal report X86 runtime.

    We are getting the following error..........

    An error has occurred while attempting to load the Crystal Reports runtime. Either the Crystal Reports registry key permissions are insufficient, or the Crystal Reports runtime is not installed correctly. Please install the appropriate Crystal Reports redistributable (CRRedist.msi) containing the correct version of the Crystal Reports runtime (x86, x64, or Itanium) required. Please go to http://www.businessobjects.com/support for more information.*

    Thanks
    Venkateswarlu

    Tuesday, June 19, 2012 9:58 AM

All replies

  • User-1584739829 posted

    This is known issue of Crystal Report runtime. Crystal report runtime is not yet fully support 64bit Windows. Here are few tips to setup.<o:p></o:p>

    1. Uninstall 64 bit runtime and install 32bit runtime
    2. Set your application pool "Enable 32bit" to true.
    3. Make sure you have write permission in c:\temp of your application pool identity.<o:p></o:p>

    Thanks

    Sunday, June 24, 2012 5:56 PM
  • User1196771204 posted

    hi there,

    In order to run Crystal Report properly, there are several things you need to check:

    1. Please make sure the crsytal report version that you used on your code MATCHES the one you instal on the server
    2. Please make sure the crsytal report assemblies that you used on your code MATCHES the one you instal on the server 
    3. Please make sure you allow FULL TRUST mode on your site/application
    4. Please make sure you set the application pool to run under LOCAL SERVICE permission
    5. Please make sure you copy the crystalreportviewer folder to your working folder.

    For Crystal Report hosting, you can always contact asphostcentral.com.

    Please mark this response as an "answer" if it helps you. Thank heaps!

    Tuesday, July 10, 2012 1:53 AM
  • User1124827950 posted

    I recently had the same problem. 

    In the Program Files in one of the Microsoft Folders (can't remember the exact location) you can find Product.xml. Just search for it. Once you locate the file open it as ADMINISTRATOR. In some cases you may not have that option. What would you need to do is to make yourself owner of the file. Then open it in Notepad or whatever program using it.  Locate the lines where you see <--86 and <--64  Comment out the lines below that. Restart your computer. It should work.

    Monday, July 30, 2012 11:25 PM