TF31002: Unable to connect to TFS 2012 with VS 2013 but I can with VS 2012 - Windows 8.1. RRS feed

  • General discussion

  • In VS 2012, I am able to connect to our TFS 2012 server.  In VS 2013, when I try to connect to the same TFS 2012 server, I get the TF31002: Unable to connect to this Team Foundation Server: http://<server>:8080/tfs.

    This is occurring on the same machine.  The only variable is the version of visual studio.  Specific version information is below.

    Windows 8.1 Enterprise / x64

    Visual Studio Ultimate 2013 /Vesion 12.0.21005.1 REL

    Visual Studio Ultimate 2012 /Vesion 11.0.61030.00 Update 4


    I started posting this as a question when I found another clue.  When entering Source Control, I received an error that stated "Key not valid for use in specified state".  After more searching I came across Trevor Hancock's post about deleting the TokenStorage key from the registry.  After following his advice, my issue was fixed.  I'm finishing this post in case it helps someone in the future with an issue similar to mine.  I am unable to post a link at this time so the instructions are quoted below.

    1. Close all instances of Visual Studio 2013
    2. Delete this folder in the registry (just “TokenStorage” – nothing else):


    • Edited by gilbert74 Tuesday, December 3, 2013 4:52 PM
    Tuesday, December 3, 2013 4:50 PM

All replies

  • HI Gilbert,

    Thanks for your post.

    And thank you for sharing your experience here. It will be very beneficial for other community members having the similar questions.

    All your participation and support are very important to build such harmonious/ pleasant / learning environment for MSDN community.

    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, December 4, 2013 2:44 AM
  • Hello gilbert74, your fix helped me very much.

    Thanks for sharing it wit us.

    /* Petr Skaloud alias ByPS */

    Tuesday, January 14, 2014 8:58 AM