none
Issue Passing Xml to BRE from BizTalk Callrules.

    Question

  • Hello,

    We have created a Business Rules Engine.  This rule has been tested properly in Rules Engine Composer.

    This BRE is published and deployed. Now I need to call this BRE from BizTalk.  I have created an Orchestration and trying to call this Rule from CallRules. Inside the CallRules policy configuration I am able to select the business policy but under the “Parameter Name” I cannot see any parameter name appearing.  So I am not able to pass xml message to bre.

    Input to the Bre is a Schema.  Following is the schema

    <?xml version="1.0" encoding="utf-16" ?>

    - <xs:schema xmlns:b="http://schemas.microsoft.com/BizTalk/2003" xmlns="http://Greatwide.LoadPlanning2.Lme.Biztalk.bre_payee" targetNamespace="http://Greatwide.LoadPlanning2.Lme.Biztalk.bre_payee" xmlns:xs="http://www.w3.org/2001/XMLSchema">

    - <xs:element name="bre_payee">

    - <xs:complexType>

    - <xs:sequence>

    - <xs:element name="bre_payee">

    - <xs:complexType>

    - <xs:sequence>

      <xs:element name="id" type="xs:string" />

      <xs:element name="company_id" type="xs:string" />

      <xs:element name="expense_glid" type="xs:string" />

      </xs:sequence>

      </xs:complexType>

      </xs:element>

      </xs:sequence>

      </xs:complexType>

      </xs:element>

      </xs:schema>

     

    I have read that “The document type must match the namespace of schema that will call it for the rule to be callable from an orchestration”. So I gave targetnamespace http://Greatwide.LoadPlanning2.Lme.Biztalk.bre_payee  to document type of bre. Still it is not working .

     

    Any  help is appreciated.

     

    Thanks

    Biju

     


    Biju Jacob
    Thursday, February 04, 2010 5:50 PM

Answers

  • Hi Biju,

    A post in past by Zeehan: http://zeetalks.wordpress.com/2008/05/11/30/ describes this scenario. It could be helpful.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly
    BizTalk Server
    Thursday, February 04, 2010 6:05 PM
    Moderator
  • I have read that “The document type must match the namespace of schema that will call it for the rule to be callable from an orchestration”. So I gave targetnamespace http://Greatwide.LoadPlanning2.Lme.Biztalk.bre_payee to document type of bre. Still it is not working
    Actually it is not the namesace you need, but the fully qualifed .NET type name.

    Go to solution explorer, click on the XSD and in the properties, you will find the fully qualified .NET type name, which is the .NET namespace and the .NET type name concatenated together. IT has nothing to do with the namespaces inside the XSD.

    eliasen, representing himself and not the company he works for.
    Three times MVP and three times MCTS in BizTalk.
    Blog: http://blog.eliasen.dk
    Thursday, February 04, 2010 6:35 PM

All replies

  • Hi Biju,

    A post in past by Zeehan: http://zeetalks.wordpress.com/2008/05/11/30/ describes this scenario. It could be helpful.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly
    BizTalk Server
    Thursday, February 04, 2010 6:05 PM
    Moderator
  • I have read that “The document type must match the namespace of schema that will call it for the rule to be callable from an orchestration”. So I gave targetnamespace http://Greatwide.LoadPlanning2.Lme.Biztalk.bre_payee to document type of bre. Still it is not working
    Actually it is not the namesace you need, but the fully qualifed .NET type name.

    Go to solution explorer, click on the XSD and in the properties, you will find the fully qualified .NET type name, which is the .NET namespace and the .NET type name concatenated together. IT has nothing to do with the namespaces inside the XSD.

    eliasen, representing himself and not the company he works for.
    Three times MVP and three times MCTS in BizTalk.
    Blog: http://blog.eliasen.dk
    Thursday, February 04, 2010 6:35 PM
  • Thanks eliasen and steef
     Now i am able to pass xml to bre.  I  changed the NameSpace + Type name in the Policy.xml and Vocabulary.xml. In that way i did not have to recreate the Policy and Vocabulary.

    Biju Jacob
    Thursday, February 04, 2010 8:00 PM
  • I have been struggling with this issue since yesterday. I made sure that the Fully Qualified Name of the schema is same as the doctype and documenttype in the policy xml.

    I am still not seeing the parameter in the Callrules Policy Configuration dialog box.

    This is what I am doing:

    1. I created a BizTalk project for my orchestration - this is where I am going be using the CallRules shape.
    2. I created a BizTalk project for my schemas - This is where my schema physically resides.
    3. I created the schema in the project created in step 2
    4. Created a policy and tested, deployed with doctype and documenttype same as fully qualified name of the schema created in step 3
    5. Added a CallRules shape in the orchestration project created in step 1
    6. Double-click the shape and select the policy in the dropdown and I don't see an option for the parameter.

    I tried many things but none seem to work.

    Any help is appreciated!

    Thursday, November 04, 2010 6:09 PM
  • Basani,

         I am facing the exact issue like you. If you resolved this issue, please share with us. Thank you.

    Friday, March 04, 2011 10:26 PM