none
Hosting service on IIS

    Question

  • I am trying to host the Northwind data service on my local server directly from Visual Studio 2008 but I get an error message when I try to access the service.

    HTTP Error 404.3 - Not Found

    The page you are requesting cannot be served because of the extension configuration. If the page is a script, add a handler. If the file should be downloaded, add a MIME map.

    The IIS manager did not have a handler for *.svc. So I added a script handler to handle *.svc with aspnet_isapi.dll and I got a new error.

    The requested content appears to be script and will not be served by the static file handler.

    Can someone point me to some resources which can solve this issue?

    Thanks!
    Monday, August 25, 2008 8:46 PM

Answers

  • Hi GuruPrasad,
     It looks like the script maps for the .svc extension are not registered. 
     You will need to run ServiceModelReg.exe -i from the "%windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation" directory to register the script maps.
    Phani Raj Astoria
    Saturday, March 28, 2009 7:59 PM
    Moderator

All replies

  • Hi GuruPrasad,
     It looks like the script maps for the .svc extension are not registered. 
     You will need to run ServiceModelReg.exe -i from the "%windir%\Microsoft.NET\Framework\v3.0\Windows Communication Foundation" directory to register the script maps.
    Phani Raj Astoria
    Saturday, March 28, 2009 7:59 PM
    Moderator
  • I've same problem on IIS 7, but this didn't solve.. :(

    svc script are registered on IIS configuration..


    Saturday, February 27, 2010 9:58 AM
  • Thanks Phani.  That put the last puzzle piece in place and I can now call services.  In addition to this issue my IIS 7 was confused between framework versions (2.0 vs. 4.0).  This post helped to sort that out: http://www.byteblocks.com/post/2010/03/25/HTTP-Error-40417-Not-Found.aspx

    /Sharon
    Tuesday, August 17, 2010 12:28 AM
  • That worked for me.  Thanks very much. 
    Friday, October 15, 2010 2:15 PM
  • That worked for me as well. Thanks I've been hunting for this solution all day.
    Friday, June 3, 2011 12:58 PM
  • I had this problem and I had to surf the Internet and read many, many articles and posts, but non of them solved my issue, except yours. Once I ran your command, bingo, the error is no longer there! Yes, it is all about the Script Maps. You're the one! Thanks!
    Friday, December 30, 2011 9:08 AM
  • Hello !

    Add a USER security in yur Data base for connection string access.

    After config your mime parameter if the .svc isn't in the list.

    Thank


    So B
    Thursday, January 5, 2012 8:49 AM
  • have yu resolved your issue ! can yu informe if that's worked please ! thank


    So B
    Saturday, January 7, 2012 3:44 PM