none
Application Settings: Clicking a value to edit it has very small click target RRS feed

  • General discussion

  • While working on an Azure Function today in the portal, I ran into a issues trying to edit the values for Application Settings. It felt like the input boxes would sometimes show up when I clicked and sometimes not. After playing with it a bit, I realized that only when I clicked directly in the middle of the row would the input box show up. Using dev tools, I highlighted the row and it showed that the clickable area was only 6px high and if you missed this short box nothing would happen. 

    I also noticed that using tab to move from the Name to the Value box does not work as expected. The focus changes from the first box to the second, but then the editable inputs immediately disappear.

    This is Chrome on a Surface Pro 4 tablet.

    Twitter link with screenshot: https://twitter.com/Tarwn/status/905214613721112577

    Chrome on Surface 4. Looks like the clickable area is only 6 pixels high. You only get an input if you click right in the middle. pic.twitter.com/EuHgP2hqJB

    — Eli Weinstock-Herman (@Tarwn) September 5, 2017
    Wednesday, September 6, 2017 1:02 AM

All replies

  • Thanks for the bug report, we were able to repro this and have filed the following issue:

    https://github.com/Azure/azure-functions-ux/issues/1753

    We'll likely have a fix deployed in 1-2 weeks.

    Wednesday, September 6, 2017 4:59 PM
  • No problem, thanks for the quick response!
    Friday, September 8, 2017 12:14 AM