locked
web root already taken RRS feed

  • Question

  • User688410599 posted

    On the server I am trying to deploy to, a web site is served directly from the root address. If several sites are on the same server usually they are set up as http:/server/site01, http:/server/site02, etc. Unfortunately this server was set up to host one site using http:/server. I need to add my application so it is accessed as http:/server/MyApp. When I try to set up the application it says the IP and port are already in use. How can I do this? Thanks

     

    Wednesday, July 25, 2007 1:40 PM

All replies

  • User-75227868 posted

    You are getting that error probably because you are trying to create a new site and providing the same ip\port\host settings as your default web site.

    I am assuming you are on a version older than IIS7. You can create a new VDir on the existing site.That will enable you to have users access to http://server/MyApp

    Open IIS UI by running inetmgr -> Right click 'Default Web Site' under 'Web Sites' node -> 'New' -> 'Virtual Directory...'. This will open a wizard where you would want to have Alias="MyApp" and Path=<the physical folder path for MyApp>

    You can now access http://server/MyApp

     

    Wednesday, July 25, 2007 2:21 PM
  • User688410599 posted

    Thanks iiscool. I added the virtual site. For security for the folder I added ASPNET and the internet guest user. The machine is several hundred miles away. I have complete access via remote desktop. I cannot view anything with the browser on the remote machine as in localhost. I can view stuff from the browser on my machine here, though. My application name is "oncall". The original web site comes up fine. When I try to view server/oncall I get a page titled "Server Error in '/oncall' Application", and it says to add <customErrors mode="Off"/>. I did that, and continue getting the server error page. I think I'm real close to getting it to work.

    Since I can't use the browser, including localhost, the problem might be database access. Maybe the database is blocked. The SQL server is on the same machine, and I put localhost in the connection string, but it probably still is not seeing that.

    I would like to enable remote error messages so I can diagnose further.

    Wednesday, July 25, 2007 3:15 PM
  • User-823196590 posted

    What version of IIS?  Did you set the folder as an application?  Did you set the right ASP.NET Framework version?

    Wednesday, July 25, 2007 3:30 PM
  • User688410599 posted

    I don't know what version of IIS and don't know how to find out. It's running Windows 2000. The ASP.NET framework version is 2.0.5027.

    Wednesday, July 25, 2007 3:50 PM
  • User688410599 posted

    IIS version 3.0

     ***********

    I don't know what version of IIS and don't know how to find out. It's running Windows 2000. The ASP.NET framework version is 2.0.5027

    Wednesday, July 25, 2007 3:54 PM