locked
Problems with databases when publishing the site... RRS feed

  • Question

  • User29532967 posted

    I've developed a site, using the Kit, everything works like a charm, when running on the developer Webserver (not a local IIS, but the IDE Webserver).

    But when publishing the website to an IIS server (with .NET 2.0 framewotk and SQLExpress installed and running) the site seems to have trouble with recognizing the users already created.

    The ASP.NET configuration tab in IIS management shows both Rolemanagemnet and Membership management activated, the correct Connections has been applied, and the site works quite normal, but The created users (created during development) are not recognized.

    I came to the conclusion (at first) that users created using the asp-admin functionality, did not correctly syncronize with the aspnet-database.I tried to create the users first using the sites functionality, and then using the web admin site to add them to the different roles. Now the useres are displayed correct, when running in the development environment, but alas, when publishing the site, no useres are recognized.

    Using the SQL Express Managment console CTP edition, and browsing through the databases (club.mdf ans aspnet.mdf), the users appear correctly in both databases.

    So my question is this : Why does the site not recognize the users created during development, when the databases are the same?

    Does it have something to do with MembershipProvider settings? Or the RoleProvider? or what?

    Kind regards,

    Martin

    Thursday, December 15, 2005 7:50 AM

All replies

  • User29532967 posted

    I solved the problem by changing the database connectionstrings in the ASP.NET confugration tab of the website's Properties. Only thing is, tha everytime i publish changes, I have to do it again.

    But at least the site is up and running, and can be viewed at http:\\kotn.martinmoesby.com.

    But beware, the site is in danish, and it's a guild site for a WoW guild in Europe.

     

    Thursday, December 15, 2005 6:19 PM
  • User-1732195092 posted

    I have the same problem with the remote server not recognizing my user especially my administrators.  I cannot add new albums or events.

    The problem is detailed here a bit more... I think it related.

    http://forums.asp.net/1148027/ShowPost.aspx

     

     

    Wednesday, December 21, 2005 8:48 PM