Classic ASP and Windows 2012 IIS Slow Performance RRS feed

  • Question

  • User-521988958 posted

    I updated the Windows 2003 server to the 2012 server. Pages using classic asp started to opening too late. All server resources are normal. CPU, memory below 50%. I think there must be a iis trick to do but I can't find it. Anybody help me?

    Sunday, August 13, 2017 2:03 PM

All replies

  • User-1315512054 posted


    Did you used some caching on the old server? Also, is the speed slow all the time or only at the first page load?


    Monday, August 14, 2017 4:44 AM
  • User-521988958 posted

    Yes i use caching both. 

    ASP pages slow all time.

    .html is ok but when i rename it with .asp, its starting to load slow. There is no code in it. Blank asp page but slow.

    I increased iis maximum worker process value today. Now faster then yesterday but its not a solution for me because sessions doesn't work.

    Monday, August 14, 2017 6:23 AM
  • User-460007017 posted

    Hi aspci2017,

    How did you set the application pool? integrated mode or classic mode? IIS 100% percent support the legacy application from IIS 6. So you could try to change application pool to classic mode.

    IIS7 should be much more faster than IIS6, You could also try to set the allowSubDirConfig to false.


    TO fix the slow performance issue, try to enable the failed request tracing to trace the performance issue. You could provide the error log which contain the procedure that make asp get slow.

    In addition, please check whether ASP feature has been enabled in turn windows features on or off.

    Just try another web browser to ensure the web browser will not have any impact on the performance.

    Best Regards.

    Yuk Ding

    Monday, August 14, 2017 7:09 AM
  • User-521988958 posted

    I give up, losing visitors and money while trying to solve the problem.

    Windows 2012 server with classic asp is fail. So long TTFB(Time to First Byte ) 5 seconds, sometimes up to 10 seconds.

    I tried everthing you write and get slow performance. I will downgrade my server to windows 2008. 

    Monday, August 14, 2017 9:48 AM
  • User-460007017 posted

    Hi aspci2017,

    To troubleshooting the performance issue, you may need to provide the error message or information. In addition, enable the application initialization and output caching should help you improve the performance.

    Best Regards,

    Yuk Ding

    Tuesday, August 22, 2017 7:22 AM