locked
Unable to remote desktop to Azure Linux VM SUSE Enterprise Server 11sp3 RRS feed

  • Question

  • Hi,

    We have created an Azure Linux VM in SUSE Linux Enterprise Server 11 SP3 . We are unable to remote desktop to that VM from Azure portal. Kindly provide help to resolve this issue

    Thanks

    Sunu Antony

    Friday, July 31, 2015 9:14 AM

Answers

  • Hi there,

    As root please run the following

    rm –f /etc/zypp/credentials.d/NCCcredentials

    rm -f /etc/zypp/repos.d/*

    Re-register the VM against the update server.

    /etc/init.d/guestregister start

    Thanks

    Vittorio


    Friday, August 14, 2015 3:05 PM

All replies

  • Hello Sunu,

    How are you trying to connect to the VM?? what's the error reported when you try to connect?

    Generally You need to configure SSH to connect to Linux VM on Windows Azure.
    Please refer below link
    https://azure.microsoft.com/en-in/documentation/articles/virtual-machines-linux-use-ssh-key/

    Hope this helps.

    Regards,
    Somashekar


    • Edited by Somashekar SK Friday, July 31, 2015 10:48 AM
    • Proposed as answer by Girish Prajwal Tuesday, August 4, 2015 6:03 PM
    • Marked as answer by Somashekar SK Wednesday, August 12, 2015 8:55 AM
    • Unmarked as answer by Somashekar SK Wednesday, August 12, 2015 8:55 AM
    Friday, July 31, 2015 10:48 AM
  • Thanks for the reply Somashekar,

    I need to login to Linux SUSE 11SP3 VM from Azure Portal using 'Connect' option (.RDP).

    The below steps were successful if we create Linux VM not in VNET. Here are the steps we followed

    1. Created a Linux VM SUSE 11 SP3 (not in VNET)

    2. Executed the below commands from putty

    sudo zypper install gnome-session
    echo gnome-session >~/.xsession
    sudo zypper install xrdp
    sudo /etc/init.d/xrdp start 

    I got the remote desktop from Azure portal after the above, but the problem is When I created a Linux VM SUSE 11SP3 in VNET, I am not able to run any of the above commands in putty. Please help

    Thanks

    Sunu Antony

    Tuesday, August 4, 2015 3:18 AM
  • Hi Sunu Antony,

    I am reproducing this issue and will get back to you at the earliest.

    Girish Prajwal

    Wednesday, August 5, 2015 6:58 PM
  • Hi Sunu Antony,

    I was able to re-produce this issue and is happening the exact same way. I will check from the back-end and suggest you at the earliest.

    I was able to execute all the commands

    sudo zypper install gnome-session
    echo gnome-session >~/.xsession
    sudo zypper install xrdp
    sudo /etc/init.d/xrdp start

    when my VM not in vnet.

    Girish Prajwal


    Monday, August 10, 2015 12:07 PM
  • Thanks Girish for the reply

    Please help as early as possible as we are running in escalation mode now.

    Wednesday, August 12, 2015 6:23 AM
  • Hi Sunu Antony,

    Request you to check on the below article for details.

    https://forums.suse.com/showthread.php?5622-New-Update-Infrastructure&p=24920#post24920

    Girish Prajwal

    Thursday, August 13, 2015 1:07 PM
  • Hi Girish,

    Thanks for the article. I tried that, but no chance.

    Thanks

    Sunu Antony

    Thursday, August 13, 2015 7:47 PM
  • Hi there,

    As root please run the following

    rm –f /etc/zypp/credentials.d/NCCcredentials

    rm -f /etc/zypp/repos.d/*

    Re-register the VM against the update server.

    /etc/init.d/guestregister start

    Thanks

    Vittorio


    Friday, August 14, 2015 3:05 PM
  • Thanks a lot Vittorio,

    It is working perfect

    Thanks

    Sunu Antony

    Friday, August 21, 2015 6:39 AM