locked
Runs on ASP.NET Development Server - deploying to IIS on same XP box results in 404s RRS feed

  • Question

  • User-1018375458 posted

    Default.aspx displays correcly, but the links to all tables result in 404s.I have tried the tip in Using the ASP.NET Routing Engine with IIS 6 on Win2K3, but then even the Default.aspx gets a 404. The site was created with the VS 2008 SP1 Dynamic Data Web Site template.

        public static void RegisterRoutes(RouteCollection routes) {
            MetaModel model = new MetaModel();
            
            //                    IMPORTANT: DATA MODEL REGISTRATION 
            // Uncomment this line to register LINQ to SQL classes or an ADO.NET Entity Data
            // model for ASP.NET Dynamic Data. Set ScaffoldAllTables = true only if you are sure 
            // that you want all tables in the data model to support a scaffold (i.e. templates) 
            // view. To control scaffolding for individual tables, create a partial class for 
            // the table and apply the [Scaffold(true)] attribute to the partial class.
            // Note: Make sure that you change "YourDataContextType" to the name of the data context
            // class in your application.
            model.RegisterContext(typeof(MATCHDataContext), new ContextConfiguration() { ScaffoldAllTables = true });
    
            // The following statement supports separate-page mode, where the List, Detail, Insert, and 
            // Update tasks are performed by using separate pages. To enable this mode, uncomment the following 
            // route definition, and comment out the route definitions in the combined-page mode section that follows.
            routes.Add(new DynamicDataRoute("{table}/{action}") {
                Constraints = new RouteValueDictionary(new { action = "List|Details|Edit|Insert" }),
                Model = model
            });
    
            // The following statements support combined-page mode, where the List, Detail, Insert, and
            // Update tasks are performed by using the same page. To enable this mode, uncomment the
            // following routes and comment out the route definition in the separate-page mode section above.
            //routes.Add(new DynamicDataRoute("{table}/ListDetails.aspx") {
            //    Action = PageAction.List,
            //    ViewName = "ListDetails",
            //    Model = model
            //});
    
            //routes.Add(new DynamicDataRoute("{table}/ListDetails.aspx") {
            //    Action = PageAction.Details,
            //    ViewName = "ListDetails",
            //    Model = model
            //});
        }
    
        void Application_Start(object sender, EventArgs e) {
            RegisterRoutes(RouteTable.Routes);
        }
     
    Wednesday, September 3, 2008 12:04 PM

All replies

  • User-1853252149 posted

    Obvious question:  Did you set the proper security for the ASP.NET process account to access the page/app?

    Jeff

    Wednesday, September 3, 2008 1:25 PM
  • User-1005219520 posted

    Unless you have XP/64 bit, XP runs IIS5, not IIS 6

    Wednesday, September 3, 2008 3:35 PM
  • User-1018375458 posted

    I hadn't changed any security settings, but since you asked, I gave ASPNET full control of the root folder of the web site and it made no difference.

    Wednesday, September 3, 2008 8:50 PM
  • User-1018375458 posted

    I'm aware that XP runs IIS 5.1. I was just sharing the fact that I tried the only related solution that I had found and it didn't work for me, in case anyone was going to recommend it.

    Wednesday, September 3, 2008 8:53 PM