locked
i-mode dev (redirection, chtml emulator) RRS feed

  • Question

  • User-796147006 posted
    Hi, I've got some problems with the redirection and with Chtml control adapter (community portal starter kit). The other mobiles adapters (wml,html) are fine. OpenWave V7 Simulator is fine to test WML. Does this tool has an "i-mode" feature ? I was wondering how to find a _light_ emulator to test i-mode access. Are there known problems around chtml, i-mode and Mobile.NET ? Thanks for your help. Pascal * With "Mimic" online test page and NEC i-mode phone no redirection occur. procedure TWebFormDefault.Page_Load(sender: System.Object; e: System.EventArgs); begin if (Request.Browser['IsMobileDevice']= 'true' ) then Response.Redirect(DEFAULT_MOBILEINDEX) else Response.Redirect(DEFAULT_DESKTOPINDEX); end; * With direct access to the mobile entry page, this exception is raised : [NullReferenceException: La référence d'objet n'est pas définie à une instance d'un objet.] MobileControls.ChtmlTabbedPanelAdapter.Render(HtmlMobileTextWriter writer) Version Microsoft .NET Framework :1.1.4322.2032; Version ASP.NET :1.1.4322.2032
    Saturday, March 5, 2005 10:33 AM

All replies

  • User-796147006 posted
    After Mobile Updates, no more redirection problem and "i-mode" adapters work fine. Super !! Borland Delphi Portal Starter Kit version : http://www.delphinaute.be/ChapsAndChips I'm always looking for a local "i-mode" emulator ? Any hints ? TIA. Pascal
    Thursday, March 10, 2005 9:37 AM