locked
SQL Session w/Farm Issue RRS feed

  • Question

  • User-1282582508 posted

    I have a web farm of two servers and an ASP.NET application configured to use SQL as the session data store.

    1) IIS is configured the same for both applications (exported from one and imported into the other) except for the IP addresses

    2) Both have the same directory structure and App ID

    3) Both have the same machine key

    4) It does have an App Web Reference

    When I deploy the application, precompiled or not, one of the servers does not pickup the session saved from the other server if accessing the website through the VIP/load balancer.  Accessing each server individually everything is fine.

    Is there anything that I may have missed or does anyone else have a suggestion?  If I deploy a previous build (the source of which was lost due to an HD crash), it works fine.  If I try to reuse the config file from that build, it still will not work.

    Wednesday, July 27, 2011 12:00 PM

All replies

  • User541108374 posted

    Hi,

    seems like some setting got in your web.config causing things to break up. Make use of beyond compare or winmerge to look for differences in the web.config of the former and the new application and spot the differences. Note that case sensitive settings sometimes hit you directly in the face if not properly taken care off.

    Grz, Kris.

    Wednesday, July 27, 2011 2:11 PM
  • User-1282582508 posted

    it's not the web.config, i've used the same one from the older build and it doesnt work.

    i think it has something to do with IIS copying the files to its temporary folder so i'll investigate it after hours not to affect any apps currently in production

    Wednesday, July 27, 2011 2:34 PM
  • User541108374 posted

    Hi,

    did the server stay the same with the same settings or was something altered in there?

    Grz, Kris.

    Wednesday, July 27, 2011 2:43 PM