locked
Disable auto complete in the Find text box in the toolbar RRS feed

  • Question

  • The auto completion function keeps trying to "correct" text i put in the toolbar's Find combo box. It happens both when typing and when copy/pasting text. I'm sure this is great for some people, but i usually copy/paste exactly what i'm looking for into the text box, which is then mangled by auto complete into something that i'm not looking for. For example, i'll copy the word "connection", then do a quick ctrl-v/enter in the Find text box and after it fails to find anything (or even worse, found the wrong thing) i'll realize it has helpfully "corrected" the term to "connectionLock."

    I realize that i can do ctrl-v/backspace/return to get the results i want, but i don't know whether or not auto complete is going to kick in for the term i'm using until after i've pasted the term in, at which point i've already hit return by reflex. I'd like to just turn auto complete off for the find textbox completely.

    I've checked Tools->Options->Environment->Find and Replace, but there don't seem to be any applicable options there. So how do i turn off auto complete in this case?

    Tuesday, September 28, 2010 4:44 PM

Answers

  • Hi Daetrin,

     

    Thanks for your post.

    As far as I know, the auto completion cannot be disabled by settings.

    But I think there are two workaround options:

    1. Could you please make the find toolwindow popup, then the completion feature will gone.

    2. Here is the location in registry to store completion strings

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\Find

    You can manually or programmatically to clear it.

    Hope this can help.

     

    Best Regards,

    Ziwei Chen

    • Proposed as answer by Victor_Chen Wednesday, October 6, 2010 6:13 AM
    • Marked as answer by Victor_Chen Wednesday, October 6, 2010 6:14 AM
    Thursday, September 30, 2010 8:51 AM

All replies

  • Hi Daetrin,

     

    Thanks for your post.

    As far as I know, the auto completion cannot be disabled by settings.

    But I think there are two workaround options:

    1. Could you please make the find toolwindow popup, then the completion feature will gone.

    2. Here is the location in registry to store completion strings

    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\10.0\Find

    You can manually or programmatically to clear it.

    Hope this can help.

     

    Best Regards,

    Ziwei Chen

    • Proposed as answer by Victor_Chen Wednesday, October 6, 2010 6:13 AM
    • Marked as answer by Victor_Chen Wednesday, October 6, 2010 6:14 AM
    Thursday, September 30, 2010 8:51 AM
  • please, please, please can we have a patch to disable this most annoying "feature". I used to use the find combo almost exclusively for searching, but now it's almost unusable, especially if you are doing case-sensitive searches.  can't believe this one got through usability...
    Friday, October 15, 2010 7:16 PM
  • I posted a comment about the same issue because I somehow failed to find this topic in a Google search. I wanted to post here to add another "vote" to get rid of this silly feature. I too find the search box unusable now. I thing that VS 2008 didn't do this so I wonder who thought it was useful to change it.

     

    Dave

     


    Dave
    Thursday, February 10, 2011 3:39 AM
  • I do agree. The find text box in the toolbar was working great in VS2008. Now it is completely unusable.

    In VS2008 I've used it to open files in my solution ">of xxx", but this does not work either thanks to te new AutoComplete feature.

    @MS: I cannot understand that it is not possible to simple restore the behavior from VS2008. Just disable AutoComplete and all should be fine.

    If you don’t understand the problem please switch on case sensitive find and try then to use the find text box. You will see that you cannot use it.

    Regards,
    Mike

     

    Saturday, July 23, 2011 4:27 PM
  • +1 I concur that the the behavior of the auto-complete "feature" does more harm than good, especially when you are attempting to perform case sensitive searches.  I would love to be able tp disable the auto-complete feature completely.

    Friday, August 26, 2011 2:55 PM
  • Seriously! How is this still an issue after a solid year! Your work-around defeats the purpose of having "Find" as a toolbar item.

    Anyone who writes case-sensitive code cannot use this feature very well!

    Everytime I go up to that box and start typing (only to get an auto-corrected first letter capitalized when I know exactly what I'm searching for) I want to smash my monitor!

    Please, actually fix this, or at least give us an option to turn the "feature" off.

     -- DW

     

    Monday, October 17, 2011 8:50 PM
  • I'm glad I'm not the only one who finds this terribly annoying. The box in its currently form is unusable in any practical situation. If you ever search for something like the word "Name" (uppercase 'N'). then basically forever, if you ever want to search for "name" lowercase, it is a pain. As soon as you press 'n' it auto-uppercases it and puts in "Name".  You can not type "name" into the box. And since the search is case sensitive, you can never find anything. You have to click on teh auto-completed item and backspace out the 'N' and enter 'n'. It is absolutely terrible!
    Tuesday, November 15, 2011 6:46 PM
  • My feelings exactly. Annoying is polite! I have encountered a few instances where I could not type in the search string by ANY trickery. In a case sensitive environment like C++, this makes searching virtually impossible! Auto complete is great, but please consider capitalization a variant from the stored string... SHOW, Show, show and sHow are NOT equivalent.
    Tuesday, November 22, 2011 5:49 AM
  • Mandatory auto complete in the find box ! ?
    Altering the case of my search ! ?
    
    Pasting text doesn't replace the previous search term ! ?
    What drunk-ass moron thought that was a good idea ! ?
    
    Whoever it was, she should be tortured live on web-cam
    around the clock -- karma.
    
    

    Tuesday, January 31, 2012 10:45 PM
  • Thanks for posting this.  

    This is a problem

    Wednesday, March 7, 2012 10:41 PM
  • I've found a solution for the selection problem. Now when I click in the find box the full text is highlighted. Before the _ and space would case the words to be half selected. Here are the steps:

    1) Click on right drop down button for the Standard Toolbar

    2) Select Remove/Add Button

    3) Select Find

    4) Press again the drop button and select Remove/Add Button

    5) Select "Go To Find" option instead

    It still suggests the texts but now less annoying...

    Thursday, March 22, 2012 2:18 PM