locked
Virtual keyboard doesn't open

    Question

  • I have a Dell Inspiron Duo, running Win 8 Dev Preview With Apps. Far too often, the virtual keyboard doesn't open at all in tablet mode. This is especially true in IE 10, where I'll click in text boxes/controls, and the keyboard icon won't display at all, not to mention the virtual keyboard won't appear.

    It isn't intuitive to know how to force the virtual keyboard to open, if that's even possible. For example, I've held my finger down and don't get any option to open the keyboard. I eventually have to open the physical keyboard of the Inspiron Duo to do any input.

    I've also had this same problem in some apps and existing programs.

    For those with slates that don't have a physical keyboard, this will present a real problem. I highly recommend following the same approach as Win 7, where the virtual keyboard could be forced open at any time by clicking on the left half of the screen.


    Jay in Atlanta
    Saturday, October 08, 2011 1:17 PM

Answers

  • Jay,

    Thank you for posting your feedback, we want to make sure we get the right info including your log files.  Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview.  There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here

    Monday, October 10, 2011 1:26 PM
    Answerer

All replies

  • I'm running on a Dell Duo myself. I don't find this issue as often as you it seems. I find the keyboard comes up pretty much when I expect it to, clicking in a text box, automatically when a text box comes up with focus. Did you manage to upgrade your Duo? I repartitioned and did a clean install in the new partition, which gave me a dual boot option. I would guess the drivers may be diferent if you did an upgrade. I have commented elswhere that a keyboard initiator icon might be useful in that panel the pulls in from the right in the Metro interface. In the standard desktop, I have a keyboard icon tacked to my notification bar on the left side at the bottom. Don't recall if I stuck it there, or it was there to start with. Incidentally, pull in the right side panel, and search for on-screen keyboard. Make sure it is looking in apps. I think you will like it.
    Saturday, October 08, 2011 8:20 PM
  • Similar issues on my Acer W500, single line text fields seem to be ok 99.9% of the time but any multi-line edit field is a bit hit and miss unless you tap in the very top left of the edit control. I'm sure this will improve (it has to) in the next release.

    I've done the same trick as Sven and added a keyboard to the Taskbar over on the desktop side but I agree a keyboard launcher should be available in Metro from the Charms bar (under 'Devices' perhaps).


    Acer W500 tablet Ageing HP laptop Too much apple stuff
    Sunday, October 09, 2011 12:06 PM
  • Jay,

    Thank you for posting your feedback, we want to make sure we get the right info including your log files.  Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview.  There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here

    Monday, October 10, 2011 1:26 PM
    Answerer