none
Windows Containers Network Timeout Settings RRS feed

  • Question

  • I have containerized our ASP.Net Web Application using microsoft/dotnet-framework:4.7.1-windowsservercore-ltsc2016 image. When I run the container in Windows 10 windows container mode if any of the web request takes more than 20 seconds client does not get any reply back and waits for the server to respond but in IIS logs inside container it logs Http Status code 200 and sc-Win32-status 121 which means "The semaphore timeout period has expired". So I was wondering if there is any network related timeout setting anywhere in docker which I can tweak to make it work. I am using "nat" network for my container. The same website works just fine in regular windows environment as well as running container under windows 2016 server.
    Thursday, June 21, 2018 2:25 PM

All replies

  • Try to put it not on NAT network but on transparent network and check if issue with type of network or container itself
    Thursday, June 21, 2018 8:30 PM
  • As you know in Windows 10 containers works in hyperv isolation mode I think it is either docker's network driver on Windows 10 or Hyper-V networking issue on Windows 10 because the same container works fine on Windows 2016 Server. 
    Thursday, June 21, 2018 9:18 PM
  • I have tried the Transparent network as well and it has the same issue with transparent network.
    Friday, July 6, 2018 8:25 PM
  • Look at this issue. It requires registry modification and running on Windows 1803. Might or might not be relevant to issue you are seeing.

    https://github.com/moby/moby/issues/34355

    Friday, July 6, 2018 8:27 PM
  • Thanks for your reply.

    I tried the registry settings and unfortunately still same behavior it times out after 20 seconds with same error in HTTPERR logs.

    Monday, July 9, 2018 9:14 PM