locked
VS 2015 Very Slow RRS feed

  • Question

  • Hi guys,

    I just installed VS 2015 community, and it's terrible! The "stickyness" and lag with it is unbearable, i can't work for more than 3mins with the IDE grinding to a halt. The CPU is up to 100% and it's consuming 2gb+RAM.

    It's so bad i've had to go back to VS 2012 just to get my work done (which is working fine)

    I've got the DevExpress suite installed and also the Project Installer Addon (which crashes when trying to click on "prerequisites") but that's all.

    Any help appreciated, i'm reinstalling everything now

    Regards,

    Richard

    Sunday, July 26, 2015 4:43 AM

Answers

  • Hi Richard,

    Thank you for posting in MSDN forum.

    For your issue, I suggest you take the following steps to troubleshoot:

    1. Reboot your machine, and open the blank visual studio to check this issue. If you have opened some other software, try to close them and rechecked this issue.

    2. Since you said that you have DevExpress plugin installed. To make sure whether it is related to your DevExpress plugin.

    Please use Devenv.exe /SafeMode, it can eliminate the possibility that third party Add-ins or packages are causing problems. Thus ensuring stable execution, Refer to: https://msdn.microsoft.com/en-us/library/ms241278.aspx?f=255&MSPPError=-2147217396

    Or go to Tools -> Add-in Manager, to disable the add-ins.

    a. If in Safe Mode, it works, I doubt that it is related to your DevExpress plugin, you could consult your issue on this forum: https://community.devexpress.com/forums/

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Or uninstall DevExpress to check this issue.

    b. If in Safe Mode, the same issue occurs, try to repair your visual studio to check whether this issue occur.

    At last, we could also use Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx ) to collect the performance, find out which thread uses high CPU. You could share the result to us.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Marked as answer by Jiayi Li Friday, August 7, 2015 9:41 AM
    Tuesday, July 28, 2015 3:07 AM

All replies

  • Hi Richard,

    Thank you for posting in MSDN forum.

    For your issue, I suggest you take the following steps to troubleshoot:

    1. Reboot your machine, and open the blank visual studio to check this issue. If you have opened some other software, try to close them and rechecked this issue.

    2. Since you said that you have DevExpress plugin installed. To make sure whether it is related to your DevExpress plugin.

    Please use Devenv.exe /SafeMode, it can eliminate the possibility that third party Add-ins or packages are causing problems. Thus ensuring stable execution, Refer to: https://msdn.microsoft.com/en-us/library/ms241278.aspx?f=255&MSPPError=-2147217396

    Or go to Tools -> Add-in Manager, to disable the add-ins.

    a. If in Safe Mode, it works, I doubt that it is related to your DevExpress plugin, you could consult your issue on this forum: https://community.devexpress.com/forums/

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites; therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there. There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Or uninstall DevExpress to check this issue.

    b. If in Safe Mode, the same issue occurs, try to repair your visual studio to check whether this issue occur.

    At last, we could also use Process Monitor (http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx ) to collect the performance, find out which thread uses high CPU. You could share the result to us.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Marked as answer by Jiayi Li Friday, August 7, 2015 9:41 AM
    Tuesday, July 28, 2015 3:07 AM
  • vs 2015is totaly grab i have tried every thing i can find on the net including this tips nothing works, my project worked fine in 2013 but not 2015  its somtimes take up to 1 min to just open a file tried to go back to 2013 but cant 2015 made some changes that is not compatible to 2013 not a suprise, but have already missed 3 deadlines its on a brand new machin withe nothing installed yet eccept vs and mysql i will never recoment vs that i former loved :(


    Morten Vagn Olsen

    Thursday, October 27, 2016 4:21 PM
  • For me this fixed it:

    https://stackoverflow.com/questions/34395686/visual-studio-2015-is-extremely-slow

    Tuesday, October 10, 2017 7:05 PM