none
Error 0x80070643 trying to add .Net 3.5.1 on W2008R2 RRS feed

  • Question

  • I have a new W2008R2 Server and I am trying to install the .Net 3.5.1 Feature. No matter what I try I get the 0x80070643 error. So far this is what I have tried.

    1) Run SFC /Scannow -- everything was fine.

    2) Ran System Update Readiness checker -- everything was OK

    3) Tried the suggestions in http://support.microsoft.com/kb/976982/en-us including the DotNet Cleanup Tool and the DonNet Fixup Tool. Neither made any difference.

    Anyone have any ideas. Thanks.


    Roger


    Monday, November 25, 2013 4:41 PM

All replies

  • Hi WaukeshaGeek,

    As this blog mentioned:http://blogs.msdn.com/b/astebner/archive/2007/03/14/mailbag-what-version-of-the-net-framework-is-included-in-what-version-of-the-os.aspx

    Windows Server 2008 R2 (all editions) includes the .NET Framework 3.5.1 as an OS component.  This means you will get the .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 plus a few post 3.5 SP1 bug fixes.  3.0 SP2 and 3.5 SP1 can be added or removed via the Programs and Features control panel.

    Windows Server 2008 R2 has .NET Framework 3.5 as a embeded feature. Have you tried to manually turn it on from Control Panel-> Turn on/off Windows feature?

    Please notice the following:

    1. 0643 is a general installation error without detail. To troubleshoot this issue, we need more details about .NET installation log.

    2. If a component is embeded on your OS. You cannot install it with a download installer. If you cannot turn on it on your OS. You have to insert your OS disc and repair it or reinstall it. It then comes to be a computer system issue.

    Please share the result when turn this feature on.

    Regards,



    Barry Wang
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, November 26, 2013 3:11 AM
    Moderator
  • Thanks for the response. In the first statement I said that I was trying to install the Feature so  I was doing exactly as you suggest. More specifically I am running a 2 line powershell shell script

    import-module servermanager
    add-windowsfeature net-framework-core

    This is what generates the error

    Thanks.


    Roger

    Tuesday, November 26, 2013 1:46 PM
  • Hi Roger,

    Sorry for the late response. However, can you just try enable this feature without powershell script?

    Regards,



    Barry Wang
    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, December 5, 2013 8:41 AM
    Moderator
  • I already have tried that and got the same result. I only did the powershell script because I got tired or bringing up server manager, selected add features etc. Plus I wanted something that was guaranteed repeatable.

    Roger


    Roger

    Thursday, December 5, 2013 1:40 PM