none
Getting exception when connecting to http://<Server>:12290/ using the example: UsingWorkflowTools. RRS feed

  • Question

  • Hi Community,

    I have a WorkflowManager installed on a WindowsServer 2012. Running at port 12290, 12291.

    From a different pc, using network tools, I'm sure i can connect to <server> 12290:12291.

    Connecting to the localhost TestServiceHost also works fine.

    However, running the exmaple UsingWorkflowTools to connect to server 2012, an exception will be raised exception at this line: (Ran as Admin)

    managementClient.CurrentScope.PublishChildScope(scopeName, new ScopeDescription()
                    {
                        UserComments = string.Format("For {0} sample only", scopeName)
                    });

    Exception:

    Unhandled Exception: 
    Microsoft.Workflow.Client.WorkflowCommunicationException: The underlying connection was closed: An unexpected error occurred 
    on a receive. Client ActivityId : 72018350-f7c0-42f7-9811-2c006a7ac760. ---> System.Net.WebException: The underlying 
    connection was closed: An unexpected error occurred on a receive. ---> System.IO.IOException: Unable to read data from the 
    transport connection: An existing connection was forcibly closed by the remote host. ---> 
    System.Net.Sockets.SocketException: An existing connection was forcibly closed by the remote host
       at System.Net.Sockets.Socket.EndReceive(IAsyncResult asyncResult)
       at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
       --- End of inner exception stack trace ---
       at System.Net.Sockets.NetworkStream.EndRead(IAsyncResult asyncResult)
       at System.Net.PooledStream.EndRead(IAsyncResult asyncResult)
       at System.Net.Connection.ReadCallback(IAsyncResult asyncResult)
       --- End of inner exception stack trace ---
       at Microsoft.Workflow.Common.AsyncResult.End[TAsyncResult](IAsyncResult result)
       at Microsoft.Workflow.Client.HttpGetResponseAsyncResult`1.End(IAsyncResult result)
       at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)
       --- End of inner exception stack trace ---
       at Microsoft.Workflow.Client.ClientHelpers.SendRequest[T](HttpWebRequest request, T content)
       at Microsoft.Workflow.Client.WorkflowManagementClient.SendRequest[T](HttpWebRequest request, T content)
       at Microsoft.Workflow.Client.ScopeManager.PublishScopeInternal(ScopeDescription description, String[] pathSegments)
       at Microsoft.Workflow.Client.ScopeManager.PublishChildScope(String childScopeName, ScopeDescription description)
       at UsingWorkflowTools.Helper.CreateManagementClient(Uri baseUri, String scopeName) in e:\projects\Using Workflow Tools 
    1.0 for Visual Studio 2012\C#\UsingWorkflowTools\Helper.cs:line 96
       at UsingWorkflowTools.Helper.PublishWorkflow(Uri baseUri, String scopeName, String activityFile, String activityName, 
    String workflowName, Boolean startWorkflow, Dictionary`2 filters) in e:\projects\Using Workflow Tools 1.0 for Visual Studio 
    2012\C#\UsingWorkflowTools\Helper.cs:line 27
       at UsingWorkflowTools.Program.Main(String[] args) in e:\projects\Using Workflow Tools 1.0 for Visual Studio 
    2012\C#\UsingWorkflowTools\Program.cs:line 48






    • Edited by AKUA28 Thursday, December 13, 2012 10:02 PM
    Sunday, December 9, 2012 9:08 PM

All replies

  • Thanks for your post!  Sorry I'm not quite clear where the problem is.

    Are you hitting the problem when trying to run the sample on another machine against the Server 2012 machine with Workflow Manager installed?

    Thursday, December 13, 2012 9:44 PM
  • Thanks for your post!  Sorry I'm not quite clear where the problem is.

    Are you hitting the problem when trying to run the sample on another machine against the Server 2012 machine with Workflow Manager installed?

    Ya, the exmaple exe is ran locally, and im im trying to connect to server 2012.
    Thursday, December 13, 2012 10:01 PM
  • Most likely you're using the wrong port. In the default settings, https is 12290 and http is 12291. So your URL should be http://<server>:12291 or https://<server:12290> 


    SharePoint architect / MCTS and MCPD SharePoint 2007 - 2013

    Wednesday, August 6, 2014 11:50 AM