none
Commerce Gateway - Order into Navision RRS feed

  • Question

  • Hello Adapter Experts.

     

    I've finally been able to send an Order from Biztalk to Navision without getting an error. Problem is... There's nothing for the Navision developer til see in the Navision Inbound table.

     

    If Biztalk doesnt give me an error routing the message does it mean that it has been delivered for sure. Are there any settings / pointers to be aware of when doing BizTalk --> Navision interchanges.

     

    On the Biztalk side I have these adapter informations:

     

    Encryption = true

     

    Correct IP

    Correct Port

     

    I've left Navision Company Name to default CRONUS International Ltd. - Can it be that this value must contain something exact ?

    Wednesday, August 13, 2008 1:07 PM

Answers

  • Performance counters are exposed by various applications which one can use to view data like Memory Usage, Processor Utilization, disc activity and lot more

     

    Start->Run-> type "perfmon"->

    This will open the performance monitor window. Right click on the main window -> Add Counters -> Click on the Drop Down box of Performance Object-> Select "BizTalk:Messaging" -> Select the radio button for "Select Counters From the list" -> Documents Processed -> On the right pane, check the radio button for "Select Instances from list" -> Select that BizTalk host instance where the adapter is running or which you want to monitor.

     

    Please make sure that you have BizTalk service running to be able to see these counters

     

    Also, let me know if you need the step by step sceen shots for reaching this performance counter.

     

    Also, I don't know if there is any particular performance counter is being exposed by the Navision adapter specifically to monitor the successful processing of the documents

     

    • Marked as answer by TBerg Tuesday, April 27, 2010 1:20 PM
    Thursday, August 14, 2008 11:08 AM

All replies

  •  

    If I am understanding the question correctly, this seems to be more like knowing whether a message has been processed by BizTalk adapter.

     

    To know this you can try to monitor the performance counter:

    BizTalk:Messaging -> Documents Processed -> The host in which your adapter is running.

     

    As soon as your document is processed by the adapter, the count will be incremented.

     

     

     

    Thursday, August 14, 2008 7:40 AM
  • You understand my question correctly Smile

     

    Excuse me for asking as this properbly reveal my limited Biztalk knowledge, but what exactly is the performance counter? - An can you be a little more specific where to find it? I have no clue at all where to look for "documents processed".

    Thursday, August 14, 2008 10:29 AM
  • Performance counters are exposed by various applications which one can use to view data like Memory Usage, Processor Utilization, disc activity and lot more

     

    Start->Run-> type "perfmon"->

    This will open the performance monitor window. Right click on the main window -> Add Counters -> Click on the Drop Down box of Performance Object-> Select "BizTalk:Messaging" -> Select the radio button for "Select Counters From the list" -> Documents Processed -> On the right pane, check the radio button for "Select Instances from list" -> Select that BizTalk host instance where the adapter is running or which you want to monitor.

     

    Please make sure that you have BizTalk service running to be able to see these counters

     

    Also, let me know if you need the step by step sceen shots for reaching this performance counter.

     

    Also, I don't know if there is any particular performance counter is being exposed by the Navision adapter specifically to monitor the successful processing of the documents

     

    • Marked as answer by TBerg Tuesday, April 27, 2010 1:20 PM
    Thursday, August 14, 2008 11:08 AM
  •  

    Okay, I used the performance counter succesfully(thank you for that lesson, never tried that before) and the count increased by 1 whenever sending an Order into Navision.

     

    So here I am... Sending an Order from Biztalk through the commerce gateway, but Navision doesnt receive it? I've tripple checked the NAS IP, the NAS Port number and the company name, which all look good. So what other pitfalls are there?

    Any ideas where to check for possbile obstacles ?

    Tuesday, August 19, 2008 12:57 PM
  • Hello Bams...

    I'm trying to build a solution that integrates CommerceServer with Navision:

    Commerce    -------  Biztalk ------  Navision
    Server


    If I understood your post right you passed the same situation. Can you give me any documentation? Or some guidelines where I can get an overall idea for this issue.

    My idea is:
    Biztalk gets FlatFiles from a specific folder in Navision and send them thru Commerce Server Adapters (the same process in the other way).

    Am I thinking right?

    Any help would be appreciated.


    Thanks in advance.

    King Regards,

    Joao Machado.


    João Machado
    Monday, March 9, 2009 3:20 PM


  • Hello!

    Can you please send me the details of the "send an Order from Biztalk to Navision".
    I am looking to integrate Navision with Biztalk.

    It would be nice if you send me any relevent document that shows step by step procedure.
    I am a student in this field and want to learn,


    Thanks in advance.
    Friday, April 3, 2009 10:12 AM
  • Hello everybody,

    I am facing an issue while integrating BizTalk Server 2006 + Commerce Gateway + Dynamics Nav 2009(Navision).

    I am done with setup and configuration as per the PDF guide provided in Commerce Gateway setup and facing below error when BizTalk tries to respond to Navision using CommerceGateway adapter.

    Error encountered on BizTalk Server:

    The adapter failed to transmit message going to send port "CommerceGateway_to_PURE-LOOK" with URL "xx.xx.xx.xxx:7527 (PURE-LOOK)". It will be retransmitted after the retry interval specified for this Send Port.

    Details:"Unexpected error in Commerce Gateway Custom Adapter.

    Original error message:

    Could not connect to source: xx.xx.xx.xxx:7527

    I checked with TELNET the mentioned IP: PORT from BizTalk machine and it gives success response.

    I hope you folks can help me on this error.

    Thanks in advance.

    Abhishek Doyle

    Friday, January 15, 2010 6:47 AM