locked
Interstitial Ads Fail RRS feed

  • Question

  • Environment:

    • Visual Studio 2017
    • Javascript UWP target Version:10.0.14393.0
    • Microsoft.Services.Store.SDK Version: 10.1703.19001

    Continually getting this error when requesting interstitial video ads: errorCode "InvalidServerResponse", errorMessage "Invalid XML". 

    I get same error when running Ad sample from here: https://github.com/Microsoft/Windows-universal-samples/tree/master/Samples/Advertising/js

    When capturing the traffic in fiddler:

    Request:

    GET https://adbroker.mp.dse.microsoft.com/v1/adbroker/ad?adm=2&cfmt=text%2cimage%2chtml5richmedia%2cpolyad&sft=jpeg%2cpng%2cgif&cltp=app&rafb=3&nct=1&idtp=mid&uid=cfcc82b6-327d-4eb6-88cb-b9386fc2ded1&pubid=<removed for this post>&pid=<removed for this post>&asid=6bd893c4a709418ab160e7386fb5c8a5&aid=27741eb3-3fe3-4a82-ae3a-c9db7badd9d8&adid=05acb0b448114d97f9f6daa7a8d5d00f&devmake=System%20manufacturer&devmodel=System%20Product%20Name&devos=WINDOWS&devosver=10.0.14393.953&devfrm=Unknown&devfam=Windows.Desktop&geoacc=2.00375e%2b07&lc=en-US&sdkversion=10.0.1703.19001&sdktype=msa-wwa-video HTTP/1.1
    X-Ads-UserAuth-Ticket: EwDoAvx9BAAUMWYi19M7exMxa8GzXWHEKTOP3igAAexIm/ID0aC0ROA0akQc/1cYUfgsO6Ayd7Ct8gidpyV0zVxbnHMuiCtftW6ygmG00ZnuXpWQMyJfTZq1S2gPABFhS6hy5cpM/fgH7dRICAu96pxi+EufnmH+eIOExy8j1AqD5Vx1ZnZwFSmuaH2FsRsoKj8BYm+8laxIX8xXIfY8+VLV525JFNtFAPRB8nbLW1/lCq+mC+h1V+/pgc+SXDGgVAJlS57sKgCuK/sEeyQ0FAe+zO/ddsWw621nagP3BweHCJRmfdvGNNEZmbquHfFb5fsbyJg4VDQHmhrfRIIXP5h2kjQ6SPDl0XP7io/1Y4+4ep8+Z2SC1OT6IpFAIDMDZgAACMZNFNGh1zi6uAFnq5qugg+xAyGEp8hBoNUt+8DaBghGl80usVawUBoDDWtIjsJEA9ga1GC1eRbLgTBPgc/UgrmmeSeFFEcaXg9GkLjKxfBpMgjd2fPxoeHWK1jmz0gsIC/4cdby4C1sRYUIziLcXZp9dpe/mltKpkbJWMoiwu0C68M7XSZeYGopckLHRWKBSzh4ykjjaY7iKyxciLgsVtF7t98wILhDS5wBbNEYkUaCCKCxnX+aZ97i1n7+ZfTjQsYqRtAYzY37ztssNhtTBd+hO8T1mUMuVBkON7eHctKLWdnr3cOG9TQq/wrUwhyIV2AQrNvF58Jj0K7M7GlVEYacjI7M+Q/9/N5+b75DHD5SYtQ91KullvqO8RdS4mqs9kbP1LOSI4xJ8G/MZ3UVRLt2vCDnzRrtdsgjygfWWqU7rkysPmaZcsdlpzyPbejM1zDLgks5IMYDe7dVg/wIWAMnf+KdAS8nM55mVrFNHhgHxcdGerWyG8L9sCbOGlRsVw95cE+CfIbTRMakERQXSpnAk0Fau9YY/2BXE62D6IJ0yRWItFyLZ8yMyN6uOUKYNMnKHy3HwMkgzynuAq/A4EOiKcAB
    Accept-Encoding: gzip, deflate
    cache-control: no-cache
    User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.79 Safari/537.36 Edge/14.14393
    Host: adbroker.mp.dse.microsoft.com
    Connection: Keep-Alive

    Response:

    HTTP/1.1 200 OK
    Cache-Control: no-store, no-cache
    Pragma: no-cache
    Content-Length: 267
    Content-Type: application/json; charset=utf-8
    Expires: Mon, 01 Jan 0001 00:00:00 GMT
    Server: Microsoft-IIS/8.5
    ARC-RSP-DBG: []
    Server: Microsoft-IIS/8.5
    X-AspNet-Version: 4.0.30319
    X-Powered-By: ASP.NET
    X-Powered-By: ASP.NET
    Date: Mon, 03 Apr 2017 03:40:50 GMT
    Connection: keep-alive

    {"adrsp":{"version":"3.0","mguid":"a9c18cd4-b33f-434f-826a-73402833bc60","type":"SingletonAd","status":"err","code":"1020","message":"Invalid value for parameter (Name: w).","ad":{"ttl":"300","cr":{"type":"TextAd","ast":[{"type":"text","name":"title","value":""}]}}}}


    Eric Roth

    Monday, April 3, 2017 4:14 AM

Answers

  • Hi Eric,

    The issue has been resolved and you should not be seeing any more errors. Please verify it.

    If you still have any problem, please create a support ticket here:http://aka.ms/storesupport .

    Thank you.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Mattew Wu Wednesday, April 5, 2017 5:48 AM
    • Marked as answer by eRock Solutions Thursday, April 6, 2017 2:59 AM
    Wednesday, April 5, 2017 5:47 AM

All replies

  • Hi Eric,

    I have tried to reproduce your problem but I cannot get the same error message. So I will report your issue to related team to check it first.

    I will update here once I have any response.

    Thanks for your patience.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 3, 2017 9:28 AM
  • Hi Eric,

    The issue has been resolved and you should not be seeing any more errors. Please verify it.

    If you still have any problem, please create a support ticket here:http://aka.ms/storesupport .

    Thank you.

    Best regards,

    Mattew Wu


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Mattew Wu Wednesday, April 5, 2017 5:48 AM
    • Marked as answer by eRock Solutions Thursday, April 6, 2017 2:59 AM
    Wednesday, April 5, 2017 5:47 AM
  • Hello Mattew,

    The error has been fixed. Now I just get the standard no ad available message, which is not really a technical problem but just a problem with using Microsoft advertising in general....

    Thanks for the quick fix on the error though.


    Eric Roth

    Thursday, April 6, 2017 2:59 AM