locked
https on Mac doesn't work for SL5 RRS feed

  • Question

  • I use both WebClient and HttpWebRequest on Windows to access https and it works fine.  Then when I test on Mac, it doesn't connect.  It reproduced on both latest verson of Firefox and Safari.  I have to workaround by changing https to http.  It should be very easy to reproduce but let me know if you need my help to reproduce.

    I am not using https or test certificate for my web server.  My app on web server is http.  And my app use both WebClient and HttpWebRequest to access https on a remote database service.  It's working perfectly on Windows.  But when I test it on the Mac, the request failed.  Changing it to http solves the problem.

    Here is the public URL I am trying to access.

    https://pokerchang.iriscouch.com/demo/_design/Startup/_view/all

    Friday, April 6, 2012 5:02 AM

Answers

All replies

  • Hi PokerIncome,

    Thanks for your post.

    I am trying to involve someone who familiar with this topic to further look at this issue.

    Best Regards,

    Monday, April 9, 2012 4:41 AM
    Moderator
  • I am not aware of any known issues regarding this scenario.

    Are you using a test certificate for your WebServer?

    Monday, April 9, 2012 1:45 PM
  • I am not using https or test certificate for my web server.  Let me clarify my original question.  My app on web server is http.  And my app use both WebClient and HttpWebRequest to access https on a remote database service.  It's working perfectly on Windows.  But when I test it on the Mac, the request failed.  Changing it to http solves the problem.

    Here is the public URL I am trying to access.

    https://pokerchang.iriscouch.com/demo/_design/Startup/_view/all

    Monday, April 9, 2012 1:53 PM
  • Your question falls into the paid support category which requires a more in-depth level of support.  Please visit the below link to see the various paid support options that are available to better meet your needs.
    http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Use VisualStudio as the product then select Libraries and then Silverlight

    Monday, April 16, 2012 6:08 PM