locked
cr not working in server - windows server 2008 RRS feed

  • Question

  • User1897897189 posted

    Dear all,

    After finishing the development , i have moved my application to test server.

    The funniest part is the crystal report is not working in server but its working absolutely fine in my development pc.

    The server is configured correct as there are many crystal report applciations working.

    pls help me

    thanks

    nick

    Monday, May 21, 2012 7:36 AM

Answers

  • User1196771204 posted

    hi there,

    It is quite normal if you are experiencing issues when deploying Crystal Report on a server. Based on the error message you experienced, it seems that you have not properly setup/configured your Crystal Report on the PC/server:

    1. If you see this error message: "Type 'CrystalDecisions.Shared.CrystalReportsException' in assembly 'CrystalDecisions.Shared, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' is not marked as serializable", this is due to the fact that your PC is unable to find the right Crystal Report version on your PC. Please try to UNINSTALL any previous Crystal Report version that you have on your system and then, please install Crystal Report for VS 2010 there. You can go tohttp://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_redist_install_64bit_13_0_1.zip (for 64 bit machine) ORhttp://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_redist_install_32bit_13_0_1.zip (for 32 bit machine) ORhttp://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_13_0_1.exe (FULL package)

    2. Once you have the CR installed on your system, please make sure you set your Crystal Report to operate on LOCAL SERVICE permission. Please check your application pool and make sure it runs under this permission

    3. Please make sure the FULL TRUST read and write permission is set on your working folder

    4. Please make sure you copy the CR aspnet_client folder to your working folder

    Once you have done all the steps above, your crystal report 2010 should work fine. If you are still experiencing problems with your host, I would truly recommend you to migrate your service to asphostcentral.com. This host has supported Crystal Report for VS 2010 and any earlier Crystal Report version.

    If this post helps you, please mark it as an answer. Good luck!

    P.S: Please always make sure you have one Crystal Report version running on your own server. If you have multiple different CR version, your report will not work!

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, May 24, 2012 11:44 PM

All replies

  • User-661350001 posted

    is the Database ConnectionString configured properly ?

    Monday, May 21, 2012 8:00 AM
  • User1897897189 posted

    yes, it is configured correctly

    Monday, May 21, 2012 8:04 AM
  • User-37275327 posted

    Check the CR version and download & install the correct runtime on the server.

    Thursday, May 24, 2012 4:17 AM
  • User-1007388224 posted

    Hi,

    I'm new on forum and I have similar problem with Crystal Report.

    vb.net2010, crystal version 13.0.2000.0

    1. In my development works fine. ( On Pc with Win7proff 32bit.)

    2. Installation is on pc win7home 64bit  (Exe, sql 2005 Express database engin, database)

    3. On Client Pc program works fine.

    4. Empty report (with no data connection on it) works fine (testing loading report)

    5. Report with data connection and dynamically binding data couse program crash .

    6. Report with data on it without binding couse error

          Failed to open the connection.     Details: Database Vendor Code: 17

    It looks like that error is on code where I bind data to report:

    ReportDocument.Database.Tables(0).SetDataSource(dsRj.Tables(0))

    Thursday, May 24, 2012 6:02 AM
  • User1196771204 posted

    hi there,

    It is quite normal if you are experiencing issues when deploying Crystal Report on a server. Based on the error message you experienced, it seems that you have not properly setup/configured your Crystal Report on the PC/server:

    1. If you see this error message: "Type 'CrystalDecisions.Shared.CrystalReportsException' in assembly 'CrystalDecisions.Shared, Version=13.0.2000.0, Culture=neutral, PublicKeyToken=692fbea5521e1304' is not marked as serializable", this is due to the fact that your PC is unable to find the right Crystal Report version on your PC. Please try to UNINSTALL any previous Crystal Report version that you have on your system and then, please install Crystal Report for VS 2010 there. You can go tohttp://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_redist_install_64bit_13_0_1.zip (for 64 bit machine) ORhttp://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_redist_install_32bit_13_0_1.zip (for 32 bit machine) ORhttp://downloads.businessobjects.com/akdlm/cr4vs2010/CRforVS_13_0_1.exe (FULL package)

    2. Once you have the CR installed on your system, please make sure you set your Crystal Report to operate on LOCAL SERVICE permission. Please check your application pool and make sure it runs under this permission

    3. Please make sure the FULL TRUST read and write permission is set on your working folder

    4. Please make sure you copy the CR aspnet_client folder to your working folder

    Once you have done all the steps above, your crystal report 2010 should work fine. If you are still experiencing problems with your host, I would truly recommend you to migrate your service to asphostcentral.com. This host has supported Crystal Report for VS 2010 and any earlier Crystal Report version.

    If this post helps you, please mark it as an answer. Good luck!

    P.S: Please always make sure you have one Crystal Report version running on your own server. If you have multiple different CR version, your report will not work!

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, May 24, 2012 11:44 PM
  • User453352941 posted

    We were getting this error too: "Failed to open the connection.     Details: Database Vendor Code: 17" when we ran reports using the CRW viewer in a ASP.NET 4.0 based app (vs.net 2010) against SQL Server 2008.

    But, we didn't get it on workstations in our LAN, only when we rolled out to a hosted cloud server running ASP.NET, IIS7, SQL2008.

    After much searching around and trying many different things, we finally found that it was caused by the fact that the TCP/IP protocol was disabled for the SQL Server box (possibly the default configuration of this hosted SQL Server install).  Our internal development SQL Server's have this enabled by default.

    To enable, use SQL Server Configuration Manager to enable TCPIP protocol (click Start, navigate to SQL Server 2008 R2, Configuration Tools, SQL Server Configuration Manager).  Open SQL Server Network Configuration, open Protocols for <servname> then enable TCPIP.  close everything and restart SQL server using SSMS by right clicking the root note and hitting restart.

    I hope this saves someone else a few hours of troubleshooting.

    Monday, December 10, 2012 3:50 PM