locked
Unable to access Central admin- Server Error in '/' Application. RRS feed

  • Question

  • Can someone help me wit below error: - I am unable to access central admin in SharePoint 2013:


    Server Error in '/' Application.



    Configuration Error

    Description:
    An error occurred during the processing of a configuration file required to
    service this request. Please review the specific error details below and modify
    your configuration file appropriately.

    Parser Error Message: The
    value of the property 'mode' cannot be parsed. The error is: The enumeration
    value must be one of the following: RemoteOnly, On, Off.

    Source
    Error:
    Line 505:  <system.web>
    Line 506:    <httpHandlers />
    Line 507:    <customErrors mode="off" />
    Line 508:    <httpRuntime maxRequestLength="51200" requestValidationMode="2.0" />
    Line 509:    <authentication mode="Windows" />

    Source
    File:
    C:\inetpub\wwwroot\wss\VirtualDirectories\5773\web.config    Line:
    507

    I have already tried flipping the "customerrors mode" from Off to On, but the issue remains the same.

    Saturday, April 9, 2016 10:56 AM

Answers

All replies

  • You should set the CallStack to true and Custom Error to off then refresh the page. It will show the orignal error.

    I have seen this error when my SharePoint VM is unable to connect to SQL.  Make sure you can ping your SQL Box from SP Box.  If SharePoint and SQL are on the same box then make sure SQL Server Service is running.

    If needed.  You can very easily re-provision the Central Administration site.

    Open SharePoint Management Shell as Farm account and run the following two commands.

    psconfig -cmd adminvs –unprovision

    psconfig -cmd adminvs –provision

    Hope this helps.


    Jerry Yasir - Office Server & Services MVP/MCT Hewlett Packard Enterprise - If this reply helped you resolve your issue, please propose as answer. It may help other community members. Thanks!

    Saturday, April 9, 2016 8:15 PM
  • You have to retype the Mode value as "Off" not as "off". These values are the case sensitive.

    set like this:

    Line 505:  <system.web>
    Line 506:    <httpHandlers />
    Line 507:    <customErrors mode="Off" />
    Line 508:    <httpRuntime maxRequestLength="51200" requestValidationMode="2.0" />
    Line 509:    <authentication mode="Windows" />

    Then you will get the error details.


    Please remember to mark your question as answered &Vote helpful,if this solves/helps your problem. ****************************************************************************************** Thanks -WS MCITP(SharePoint 2010, 2013) Blog: http://krossfarm.com

    Sunday, April 10, 2016 1:15 AM
  • Jerry and Waqas Thank you for reply,

    After changing retype the Mode value as "Off" I came to know its SQL issue. Though I am able to ping SQL and telnet is working but UDL test is failing.

    I am getting below error in SQL server.

    Log Name:      Application
    Source:        ESENT
    Date:          4/10/2016 11:38:35 AM
    Event ID:      489
    Task Category: General
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SQL.net.com
    Description:
    sqlservr (5052) An attempt to open the file "C:\Windows\system32\LogFiles\Sum\Api.log" for read only access failed with system error 5 (0x00000005): "Access is denied. ".  The open file operation will fail with error -1032 (0xfffffbf8).
    Event Xml:
    <Event xmlns=
      <System>
        <Provider Name="ESENT" />
        <EventID Qualifiers="0">489</EventID>
        <Level>2</Level>
        <Task>1</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2016-04-10T11:38:35.000000000Z" />
        <EventRecordID>2182</EventRecordID>
        <Channel>Application</Channel>
        <Computer>SQL.net.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>sqlservr</Data>
        <Data>5052</Data>
        <Data>
        </Data>
        <Data>C:\Windows\system32\LogFiles\Sum\Api.log</Data>
        <Data>-1032 (0xfffffbf8)</Data>
        <Data>5 (0x00000005)</Data>
        <Data>Access is denied. </Data>
      </EventData>
    </Event>

    I found below KB, but still SP is not able to connect with SQL

    KB 2811566

    Sunday, April 10, 2016 6:26 PM
  • Can you make sure you Firewall on SQL Server is either turned off you can add the firewall rules to Open 1433 port for SharePoint connectivity?


    Jerry Yasir - Office Server & Services MVP/MCT Hewlett Packard Enterprise - If this reply helped you resolve your issue, please propose as answer. It may help other community members. Thanks!

    Sunday, April 10, 2016 7:09 PM
  • Yes the firewall if off and port 1433 is open, I can do telnet from SharePoint box to SQL on port 1433.

    it looks like authentication issue or may be bug in SQL 2012

    Sunday, April 10, 2016 9:34 PM
  • Hi Ashish,

    Please right-click \Windows\System32\LogFiles\Sum folder, and click Security tab, click Edit, add the service account that is used by SQL server, and grant Full control permission on the service account.

    If the above doesn't work, I suggest you create a new thread on SQL Server forum. The reason why we recommend posting appropriately is you will get the most qualified pool of respondents, and other partners who read the forums regularly can either share their knowledge or learn from your interaction with us.

    Thank you for your understanding.

    SQL Server forum:

    https://social.technet.microsoft.com/Forums/sqlserver/en-US/home?category=sqlserver

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, April 13, 2016 6:46 AM
  • Hello all,

    Thank you for the reply,

    I have rebuild the farm now.

    Thursday, April 14, 2016 11:55 AM