none
Enable text cursor blinking in Windows 8 RDP RRS feed

  • Question

  • Hi,

    Looks like text cursor blinking is always disabled in Window 8 RDP session. The PERF_DISABLE_CURSORSETTINGS flag has not effect on Windows 8 RDP session.

    Tried on MS RDC too and had the same result.

    Is there a way to enable it?

    Regards,

    Walter

    Monday, March 25, 2013 7:05 PM

Answers

  • "looks like there is no way to enable the text cursor blinking on Windows 7/8."

    In fact, there is a way to enable the text cursor blinking.  You just have to enable a registry setting on the host. (The discussion until now has been about the client.)

    You can run the following on the command-line (with "run as administrator") :

    REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" /v "CursorBlinkEnable" /t REG_SZ /d 1

    REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" /v "CursorBlinkEnable" /t REG_SZ /d 1

    Source: KB873418   (You don't need the hotfix, just the registry setting.)

    I tested this on a Windows 8.1 computer with Notepad and Word. It blinks as advertised.


    • Proposed as answer by Eric Cote Friday, March 14, 2014 12:59 AM
    • Edited by Eric Cote Friday, March 14, 2014 1:02 AM
    • Marked as answer by Walter Yongtao Wang Saturday, March 15, 2014 2:51 AM
    Friday, March 14, 2014 12:53 AM
  • Hi Walter,

    I reviewed this for you and the Microsoft RDP client MSTSC always clears [MS-RDPBCGR] 2.2.1.11.1.1.1  Extended Info Packet (TS_EXTENDED_INFO_PACKET).PerformanceFlags.PERF_DISABLE_CURSORSETTINGS (0x00000040), even if it was set in the .RDP file via “disable cursor setting:i:1”.  I checked the MSTSC.EXE code back to Windows XP.  Accordingly, it is not possible to establish a RDP session using the Windows MSTSC client that will pass this flag.  So, the behavior Windows-to-Windows using MSTSC should be consistent between Windows versions.  I did not check mstscax.dll, which is used by utilities like VMConnect.

    Other clients may use this flag, but the Microsoft client does not.

    Are you observing that there is a behavior change between when your client remotes to Windows 7 (using RDP7x) v Windows 8 (using RDP8) when setting this flag?  I did a brief test from a Windows 8 box (modified to pass this flag) and both a Windows 7 and Windows 8 remote system.  I did not observe a change in behavior (in both cases, using Notepad, I did not see the vertical-bar cursor blinking).


    Bryan S. Burgin Senior Escalation Engineer Microsoft Protocol Open Specifications Team

    Tuesday, March 26, 2013 11:22 PM
    Moderator

All replies

  • Walter,

    If your question is about testing configuration settings on the PerformanceFlags of Windows-based Rdp clients, the following forum would the most appropriate to help:
    Remote Desktop Services (Terminal Services)
    http://social.technet.microsoft.com/Forums/en-US/winserverTS/threads

    However, if you are implementing the RDP protocols, e.g. MS-RDPBCGR 2.2.1.11.1.1.1 “Extended Info Packet (TS_EXTENDED_INFO_PACKET)”,
    and has questions on how this would appear on the wire, this forum may be able to assist.
    If that is the case, let us know which document MS-XYZ and sections you need assistance with.


    Thanks,
    Edgar

    Monday, March 25, 2013 9:45 PM
    Moderator
  • Hi Edgar,

    Yes. I'm implementing my RDP client.

    According to [MS-RDPBCGR] 2.2.1.11.1.1.1, performanceFlags can have this flag:

    PERF_DISABLE_CURSORSETTINGS 0x00000040 Disable cursor blinking

    But I don't think this works (It can not disable the cursor blinking on XP, 2008 etc); or is this not for text cursor blinking?

    Actually I don't care it can not disable the text cursor blinking. I need to find a way to enable the text cursor blinking on Windows 8, but seems there is no way to do that, to confirm that, I also tried MS RDC.

    Thanks,

    Walter

    Monday, March 25, 2013 10:22 PM
  • Hi Walter,

    I reviewed this for you and the Microsoft RDP client MSTSC always clears [MS-RDPBCGR] 2.2.1.11.1.1.1  Extended Info Packet (TS_EXTENDED_INFO_PACKET).PerformanceFlags.PERF_DISABLE_CURSORSETTINGS (0x00000040), even if it was set in the .RDP file via “disable cursor setting:i:1”.  I checked the MSTSC.EXE code back to Windows XP.  Accordingly, it is not possible to establish a RDP session using the Windows MSTSC client that will pass this flag.  So, the behavior Windows-to-Windows using MSTSC should be consistent between Windows versions.  I did not check mstscax.dll, which is used by utilities like VMConnect.

    Other clients may use this flag, but the Microsoft client does not.

    Are you observing that there is a behavior change between when your client remotes to Windows 7 (using RDP7x) v Windows 8 (using RDP8) when setting this flag?  I did a brief test from a Windows 8 box (modified to pass this flag) and both a Windows 7 and Windows 8 remote system.  I did not observe a change in behavior (in both cases, using Notepad, I did not see the vertical-bar cursor blinking).


    Bryan S. Burgin Senior Escalation Engineer Microsoft Protocol Open Specifications Team

    Tuesday, March 26, 2013 11:22 PM
    Moderator
  • I Bryan,

    I tested it again. My memory is not exactly correct. On XP, this flag has no effect. The text cursor always blink on XP. On Windows 7. The text cursor will blink only one time. On Windows 8, the text cursor will not blink at all.

    Thanks for clarifying that, looks like there is no way to enable the text cursor blinking on Windows 7/8.

    Really appreciate your help.

    Walter

    Wednesday, March 27, 2013 2:53 AM
  • "looks like there is no way to enable the text cursor blinking on Windows 7/8."

    In fact, there is a way to enable the text cursor blinking.  You just have to enable a registry setting on the host. (The discussion until now has been about the client.)

    You can run the following on the command-line (with "run as administrator") :

    REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" /v "CursorBlinkEnable" /t REG_SZ /d 1

    REG ADD "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server" /v "CursorBlinkEnable" /t REG_SZ /d 1

    Source: KB873418   (You don't need the hotfix, just the registry setting.)

    I tested this on a Windows 8.1 computer with Notepad and Word. It blinks as advertised.


    • Proposed as answer by Eric Cote Friday, March 14, 2014 12:59 AM
    • Edited by Eric Cote Friday, March 14, 2014 1:02 AM
    • Marked as answer by Walter Yongtao Wang Saturday, March 15, 2014 2:51 AM
    Friday, March 14, 2014 12:53 AM
  • Is there any explanation as to why the cursor becomes invisible when the blinkcursor is disabled in rdp mode? Why won't it display a non-blinking cursor instead of becoming invisible?For example in rdp mode the command prompt it just shows a non-blinking cursor
    Monday, September 15, 2014 9:17 AM
  • Hi Nitilakasha,

    I never saw the cursor is invisible when blinkcursor is disabled? Are you using Microsoft RDP client? it's probably a bug on the RDP client.

    Monday, September 15, 2014 2:42 PM
  • Yes I am using microsoft RDP client. The cursor(Caret) doesn't appear in the application when EnableBlinkCursor key is not added in registry. When I add this key it all works fine. My question is why wont it just display a non-blinking when the key is deleted. FYI  I am trying to display a blinking caret in a textbox with black background. How does enabling blinking make it visible? However this is happening only in my application. The other applications (notepad) show non blinking cursor. I don't know what I am missing. The application displays the caret properly for a local system.
    Thursday, September 18, 2014 9:15 AM