locked
RDL Rendering (500 Internal Server) Error at Sharepoint Integrated Reporting Service RRS feed

  • Question

  • I have a serious problem that cannot be solved by googling around the keywords below:
    sharepoint, moss 2007, reporting service, ssrs 2008, rendering, internal server error, ....

    The error is;

    "An error occurred during client rendering. The remote server returned an error: (500) Internal Server Error. "

    Everything is O.K.;

    * When I render the report from the REPORTSERVER (http://localhost/ReportServer)
    * When the reports are scheduled to be sent by the reporting service (planned via MOSS 2007) 

    But if I open (render) the RDL file from the sharepoint REPORTS LIBRARY interface, all of the reports fail with that internal error message above. 

    It is weird also that parametrized reports are displayed without errors although the parameters are queried from a sql dataset. But I got the error when rendering the report after I've chosen a parameter  and order "apply/report"...

    Possible causes how I met that error may be;

    After I have installed (then uninstalled) AJAX extensions
    After I have re-configured IIS Web Service Extensions list items

    Possible solution alternatives I've found;

    I've found a solution on MSDN replying a similar issue with an ideal cause of the error but an evreka answer but no solution suggestion from the author.

    What the guru says is; "The report is successful in reporting services, but SharePoint never gets and renders the report.  You can check your wait times in RS and SharePoint(ASP).  When we checked them RS was 9000 and SharePoint was 2000.  When we increased the SharePoint, the report rendered."

    But how? See detail at
    http://social.msdn.microsoft.com/Forums/en-US/sqlreportingservices/thread/65f5db23-1a6a-47fc-8bf6-b90b9ce1fff0

    I'll appreciate for the exact match to my trouble :(

    Friday, July 10, 2009 11:43 AM

Answers

  • Hi,

    Today while i was wrking, i had the same issue.When Anonymous Access was enabled(ISS-> Security) this was happening.When i unchecked the option i am not getting this error.Try disabling anonymous Access if u have enabled it.It would wrk.


    Cheers,
    Raghav
    • Proposed as answer by Raghav_Prasad Tuesday, December 15, 2009 6:01 AM
    • Unproposed as answer by Mike Walsh FIN Thursday, February 25, 2010 4:49 AM
    • Proposed as answer by DTGrayston Friday, February 26, 2010 11:58 PM
    • Marked as answer by Mike Walsh FIN Saturday, February 27, 2010 8:29 AM
    Monday, December 14, 2009 1:33 PM

All replies

  • Hello Jurnalist,

    Regarding your issue,

    Did you checked the log files of Report Server?

    can you go to the IIS error log file and check it?
    (c:\WINDOWS\system32\LogFiles\HTTPERR)
    We will maybe able to get more information.

    I know a case where someone had exactly the same issue and he was using SSL for Report Server. But we did not look further...

    Hope that helps.

    Marc
    Friday, July 10, 2009 5:15 PM
  • Thanks Charmois for your reply, I'll check it at the office. But is it really a ReportServer based problem or a Sharepoint based problem??
    Because I can render any reports on ReportServer...

    Where can I check if I have a SSL level for SSRS? It was working well with Sharepoint Integrated mode before I had some tests with AJAX ve WS extensions...
    Would it be stand up and clear the problem if I re-install SSRS add-in for MOSS?!
    Sunday, July 12, 2009 1:19 PM
  • No clue at C:\WINDOWS\system32\LogFiles\HTTPERR last log is 2 days ago although I receive the error just now :(

    Monday, July 13, 2009 5:21 AM
  • hello
    did you resolve this problem. I have just started getting it

    cheers
    Craig
    Friday, October 16, 2009 5:42 AM
  • Hi,

    Today while i was wrking, i had the same issue.When Anonymous Access was enabled(ISS-> Security) this was happening.When i unchecked the option i am not getting this error.Try disabling anonymous Access if u have enabled it.It would wrk.


    Cheers,
    Raghav
    • Proposed as answer by Raghav_Prasad Tuesday, December 15, 2009 6:01 AM
    • Unproposed as answer by Mike Walsh FIN Thursday, February 25, 2010 4:49 AM
    • Proposed as answer by DTGrayston Friday, February 26, 2010 11:58 PM
    • Marked as answer by Mike Walsh FIN Saturday, February 27, 2010 8:29 AM
    Monday, December 14, 2009 1:33 PM
  • That worked for me!
    Tricia Wilcox Almas
    Tricia Wilcox Almas
    Thursday, February 25, 2010 1:21 AM
  • Raghav_Prasad.

    Please don't not propose your own posts as answers. It isn't helpful.

    Propose the good answers of other people but wait for someone else to propose your posts.


    (Moderator)


    Note to all: he marked it within 24 hours of posting it and over two months before a response to it came into the forum.

    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Thursday, February 25, 2010 4:50 AM
  • 3 posts in a day for an 8 month old thread ;) ....anyway I'll propose it as *an* answer.
     
    I was suddenly experiencing similar 500 errors when rendering reports on an otherwise fully working Sharepoint RS integrated site. After trying a number of other fixes (re-installing the RS-Addin, restoring Farm from backup, etc...) I found this post and then recalled I did hit the Enable Anon access while troubleshooting some unrelated issue.  Go into,

                Central Administration | Application Management | Authentication Providers | click Default (link) and uncheck Enable Anonymous

    Went back into our site and the reports are now rendering again.  Cheers.

    Saturday, February 27, 2010 12:14 AM
  • > anyway I'll propose it as *an* answer.

    Thanks. In view of the "That worked for me!" reply, that's what I was waiting for,


    (Moderator)
    FAQ sites: (SP 2010) http://wssv4faq.mindsharp.com; (v3) http://wssv3faq.mindsharp.com and (WSS 2.0) http://wssv2faq.mindsharp.com
    Complete Book Lists (incl. foreign language) on each site.
    Saturday, February 27, 2010 8:28 AM
  • Hi,

    Today while i was wrking, i had the same issue.When Anonymous Access was enabled(ISS-> Security) this was happening.When i unchecked the option i am not getting this error.Try disabling anonymous Access if u have enabled it.It would wrk.


    Cheers,
    Raghav


    I need to have Anonymous Access enabled so this solution does not work for me.

    Anyone found the reason for this error?

    • Proposed as answer by Swati Parmar Saturday, August 7, 2010 11:14 AM
    Thursday, July 15, 2010 10:37 AM
  • Thanks I got pointers from this blog.

    Proposed Solution that worked for me was in IIs in Application Pool check properties of your application ->click identity choose configrable and put same login that is there for working Application.(check working applications identity)

     

    Saturday, August 7, 2010 11:19 AM
  • I was also getting this error on one server in my SharePoint farm and direct report execution worked fine. After eliminating all of the other suggestions I noticied that in IIS the host header binding configured for this web app was different on one of the members of the farm. After correcting the binding (making it consistent with the other farm members) the Internal Error went away and the reports rendered correctly.
    Brad Turner, ILM MVP - Ensynch, Inc - www.identitychaos.com [If a post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of that post. By marking a post as Answered or Helpful, you help others find the answer faster.]
    Thursday, November 11, 2010 10:08 PM
  • Made my day. Thanks a lot. It worked for me..!! Im running Reporting Services with Sharepoint Integrated mode.
    Wednesday, February 2, 2011 11:15 AM