none
Reboot Issue after Meltdown Patch RRS feed

  • Question

  • Hi everyone,

    I have a problem with the last patch of Windows concerning the Meltdozn issue. I have a device with the following processor and mother board  :

    • Processor Intel Atom E3845
    • Motherboard AsRock SBC-211

    I have installed the last Windows update "Windows6.1-KB4056897-x64”. Then when we restart the device, it happens sometimes (at least every 4 or 5 five restart) that the turret doesn’t boot again and end with a black screen. It’s difficult to say in which state the device is (trying to shutdown, trying to start the device,…).  Ewf is enabled on the device.

    Anyone can help ? Thank you for your time !

    • Moved by Bruce Eitman Thursday, January 25, 2018 9:33 PM Posted to Windows Compact forums, should be WES
    Monday, January 22, 2018 1:41 PM

All replies

  • Hi Alex,

    When you applied the patch you re-build the image.  Did you change any settings? Have you reviewed the boot order?  What debugging have you done?  Unfortunately, this behavior is likely unique to your setup so will require you to do some digging.

    Sincerely,

    IoTGirl

    Monday, January 22, 2018 6:23 PM
  • Hi IoTGirl,

    First of all, thank you for your answer.

    No, I haven't change any settings. The boot order is the same (most of times, there is only one disk to boot). I tried to see if Windows generate some dump but nothing. There is nothing special in the Event Viewer neither. All seems to go in the right way but the device doesn't restart correctly.

    Regards,

    Alex

    Tuesday, January 23, 2018 7:50 AM
  • Hi Alex,

    Your statement:

    ...but the device doesn't restart correctly.

    Would lead me to assume that configuration data that is created on first boot is getting corrupted or not stored as expected. Did the new build change the size/locations in Memory? If you look at the memory layout on the old build versus the new build do you see any changes in page boundaries etc?

    Again, you are likely going to have to dig around to find this in your solution as none of us will have your exact setup. If your setup was supplied to you by and OEM/BSP provider/Distributer, you should be able ask them for support as well.

    Sincerely, IoTGirl

    Wednesday, January 24, 2018 5:35 PM
  • Is there a way I could check if the configuration data are corrupted or stored at the wrong place ?

    I see no difference in the memory. How can I check the page boundaries ? Ewf is enabled on the system. Can it play a role in the problem ?

    I already ask for support but they can't reproduce the problem.

    Again thank you for your time :)

    Regards Alex Stalmans


    • Edited by AlexStalmans Thursday, January 25, 2018 12:24 PM
    Thursday, January 25, 2018 11:06 AM
  • Alex

    That is a question that you or your board vendor are going to need to answer.  You haven't told us where anything is stored on your device.

    Wait, is this a Windows Compact question?  Or is it for Windows Embedded Standard?  EWF isn't a Windows Compact feature, but is for WES.  I will move this discussion to a WES forum.


    Bruce Eitman
    Senior Engineer
    Bruce.Eitman AT Synopsys DOT com
    My BLOG http://geekswithblogs.net/bruceeitman
    I work for Synopsys

    Thursday, January 25, 2018 9:32 PM
  • Which version of Windows are you using?

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, January 25, 2018 10:39 PM
    Moderator
  • It's a Windows Embedded Standard. Sorry, it's the first time I use this forum to get help from the community, so I'm little confused. I'll move this this discussion to another forum.

    Alex Stalmans

    Friday, January 26, 2018 7:20 AM
  • Windows 7 Embedded Standard SP1.

    Alex Stalmans

    Friday, January 26, 2018 7:20 AM
  • I'm having the same issue as Alex on a E3845 platform with WES7. I'm also using EWF.

    I tried booting a completely vanilla installation of WES7 with no updates installed then installed KB4056897. Every fourth or fifth reboot will hang.

    The OS shuts down, the monitor turns off, the USB ports are powered off, but the system never comes back up.

    Monday, February 5, 2018 5:18 PM
  •  There have been a number of complaints about the various OS patches for meltdown. It appears the patches have been rushed out there. This has to be elevated to Microsoft directly.

    Have either of you applied any BIOS updates for your platforms?


    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com


    Tuesday, February 6, 2018 3:53 AM
    Moderator
  • I tried a new BIOS update from my board vendor but nothing change.
    Tuesday, February 6, 2018 11:01 AM
  • I have as well. I also tried toggling some ACPI options in the BIOS to no affect. We took the plunge and paid for MS Support to look at the issue. I'll report back.

    Tuesday, February 6, 2018 2:10 PM
  • Have you got any more news ?

    Monday, February 12, 2018 9:19 AM
  • I asked for an update this morning (it had otherwise been quiet). They asked if I was using an AMD processor. -_-

    I don't think they've started looking into the issue yet, which is a bit frustrating given how much money we paid.

    Wednesday, February 14, 2018 9:15 PM
  • Hmm, are you using an AMD chip?  Their question leads me to believe that maybe there is an Intel only instruction that might be involved and that they may have done some digging.
    Thursday, February 15, 2018 5:56 PM
  • I have had a similar problem on multiple types of PCs that are 4+ years old, running standard Win 7 Pro x64. Restarting is not reliable after the Windows Update with the Meltdown patch.

    I did find a workaround for my PCs, but it's still a problem that needs to be properly fixed. I disabled the power-saving C-states in my BIOS, and the machines use a lot more power, but restarts properly.

    See also these threads:

    https://answers.microsoft.com/en-us/windows/forum/windows_7-update/dell-vostro-260-fails-to-restart-after-kb4056894/3babf0a4-aa96-4356-9fff-b09cb13d1155

    https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/restart-no-longer-functions-normally/46e5a8e6-0488-456f-8849-5849049e0b1d

    https://answers.microsoft.com/en-us/windows/forum/windows_7-performance/windows-7-hangs-on-reboot-after-applying/ea13e25f-f41c-4067-93c0-f249857ed018

    Friday, February 16, 2018 5:08 PM
  • Hi Alan,

    That tracks.  Some older chips do not support some newer Intel instruction sets.  Do you have details on those chips?  That would help eliminate that path of investigation if someone could give specific details of the CPUs that are failing versus the ones that are not.  I would expect the Atom mentioned in the original post would be fairly new, however, but I am not familiar with it enough or the path of investigation to know for sure.

    Sincerely,

    IoTGirl


    Friday, February 16, 2018 6:06 PM
  • I'll give this a try on the E3845 platform we're seeing the issue on.

    EDIT:

    Yeah, it looks like disabling higher c-states resolves the hanging reboot issue. Sadly, this is not an option for our devices which are to be remotely updated. It should help Microsoft pinpoint the issue, though.

    Monday, February 19, 2018 3:59 PM
  • I tried too and the problem seems solved but I'm in the same situation than Jon. All our device must be remotely updated. I hope Microsoft will release a new update soon.
    Tuesday, February 20, 2018 11:18 AM
  • Any more news from Microsoft ?

    Thursday, March 8, 2018 2:18 PM
  • The latest Security Monthly Quality Rollup for Windows 7.0 SP1 (i.e. KB4088875 released on March 13th 2018) provides the cumulative Spectre & Meltdown fixes.

    https://support.microsoft.com/en-us/help/4088875/windows-7-update-kb4088875

    Friday, March 30, 2018 11:29 PM
  • Thanks for the update to the thread Shoeb!
    Saturday, March 31, 2018 2:40 PM