none
Unable to re-install FSLogixAppsSetup Windows 2019 RDSH RRS feed

  • Question

  • Hello. I installed FSLogix for App Masking on Windows Server 2019 VM with RDSH role. Users configured with Roaming Profiles and Folder redirection. 
    I applied about 15 rules and all working as expected.
    Next day FSLogix Apps Services (frxsvc) had stopped and would not start again. Un-installed all FSLogix applications, rebooted and tried to re-install
    FSLogixAppsSetup (version 2.9.7349.30108) several times again. But no success and it ends up with the same Error "Failed to start redirector driver (0x80070002), 
    and this message in logfile every time:

    [0FF4:1278][2020-10-15T11:21:52]i301: Applying execute package: FSLogixAppsSetup, action: Install, path: C:\ProgramData\Package Cache\{98BEF1EB-609D-4C0F-8FF1-FA0C17CF7108}v2.9.7349.30108\FSLogixAppsSetup.msi, arguments: ' ALLUSERS="1" ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" INSTALLFOLDER="C:\Program Files\FSLogix\Apps"'
    [0FF4:1278][2020-10-15T11:22:07]e000: Error 0x80070643: Failed to install MSI package.
    [0FF4:1278][2020-10-15T11:22:07]e000: Error 0x80070643: Failed to execute MSI package.
    [0970:09EC][2020-10-15T11:22:07]e000: Error 0x80070643: Failed to configure per-machine MSI package.
    [0970:09EC][2020-10-15T11:22:07]i319: Applied execute package: FSLogixAppsSetup, result: 0x80070643, restart: None
    [0970:09EC][2020-10-15T11:22:07]e000: Error 0x80070643: Failed to execute MSI package.

    So far I have tried latest Windows Update, different version of VMware Tools. Installation run as Domain Enterprise admin and local admin.
    I have run netfxrepairtool, sfc/scannow but no success.
    I have no more ideas, and would appreciate any help the resolve this issue.

    Best Regards,
    Tommy Åkerberg
    Thursday, October 15, 2020 2:36 PM