locked
How is possible to pass the test with WACK 3.1 for apps published with WACK 2? RRS feed

  • Question

  • Hi,

    4 month ago I passed the test.

    Now I wanted to check what happen with WACK 3.1 and I didn't pass.

    I have the error:

    Performance launch

    • Error Found: The performance launch test collected the following results:.
      • Application Error: Application Launch was not detected for application App. This could be because your application failed to launch correctly. Please consider re-running the test and avoid interacting with the application while tests are running.
    • Impact if not fixed: Application launch time is important for creating a fast and fluid experience for the user. This app will not be accepted by the Windows Store.
    • How to fix: You should ensure that your app’s performance is consistent across different machine configurations and does not exceed the minimum requirements or it will potentially fail during Windows store onboarding. The informational metrics can provide insight into areas that could help improve your app’s performance, but do not impact your apps acceptance by the Windows Store. See link below for more information

     

    What is changed and what I suppose to do to be able to do minor changes?

    Thanks


    ADRIAN DIBU

    Friday, November 15, 2013 12:05 AM

Answers

  • Hi ,

    When you launch the WACK don't touch anything else. And when I say anything else don't even go to your desktop to do another job.

    I 've noticed in my case that everytime I run the WACK and pressed for example the windows button to return to the desktop the test FAILS. 

    Also in my case I'm running the test from a vmachine which loads the windows 8. Sometimes I have performance errors(after a restart of the VM everything is restored).

    If I were you I would these.

    First of all a restart. Not needed but just in case.

    Second run the WACK for your app and go for coffee. Don't touch anything , not even the mouse , just let it finish. I think after 10 minutes you should be OK. In my case I need 10-15 minutes becasue I run a VM.

    Although sometimes it gets tricky and you think that the WACK finished but it didn't . That is why I'm saying let it finish and if you are lucky you will see the Finish results screen. Be aware. Sometimes it goes on the back and you will have to press VStudio Icon which is minimized to see what happened. And if the test didn;t finish you will get the error and forced to start all over again.

    The main issue is that if you press by accident something even click with your mouse you will get this error. Don't know why this is happening but when I run the test I leave my office go for cup of coffee and come back again.

    At least it works.

    Hope I helped you

    thank you


    • Edited by zakkar Friday, November 15, 2013 2:33 PM
    • Marked as answer by adibu Saturday, November 16, 2013 2:25 PM
    Friday, November 15, 2013 2:31 PM

All replies

  • Hi,

    I have 3 apps published 4 month ago.

    If I try to update or even the exact app to test with WACK 3.1 I have the same answer.

    Please somebody be so kind to explain what happen with WACK 3.1,

    Best regards

    ADRIAN DIBU

    Friday, November 15, 2013 2:04 PM
  • Hi ,

    When you launch the WACK don't touch anything else. And when I say anything else don't even go to your desktop to do another job.

    I 've noticed in my case that everytime I run the WACK and pressed for example the windows button to return to the desktop the test FAILS. 

    Also in my case I'm running the test from a vmachine which loads the windows 8. Sometimes I have performance errors(after a restart of the VM everything is restored).

    If I were you I would these.

    First of all a restart. Not needed but just in case.

    Second run the WACK for your app and go for coffee. Don't touch anything , not even the mouse , just let it finish. I think after 10 minutes you should be OK. In my case I need 10-15 minutes becasue I run a VM.

    Although sometimes it gets tricky and you think that the WACK finished but it didn't . That is why I'm saying let it finish and if you are lucky you will see the Finish results screen. Be aware. Sometimes it goes on the back and you will have to press VStudio Icon which is minimized to see what happened. And if the test didn;t finish you will get the error and forced to start all over again.

    The main issue is that if you press by accident something even click with your mouse you will get this error. Don't know why this is happening but when I run the test I leave my office go for cup of coffee and come back again.

    At least it works.

    Hope I helped you

    thank you


    • Edited by zakkar Friday, November 15, 2013 2:33 PM
    • Marked as answer by adibu Saturday, November 16, 2013 2:25 PM
    Friday, November 15, 2013 2:31 PM
  • The tests have got tighter as time goes on.

    MS say this makes the apps better for users.

    I found loading in data from a file on power up sometimes caused this problem.

    The only other problem I had was with c++ and directx and that was the Trim function is needed on suspend.


    n.Wright

    Friday, November 15, 2013 9:38 PM