none
Excel COM Add-in will install but not launch from one pc, but ok on another RRS feed

  • Question

  • Ive build a COM add-in with VS 2012 and its working ok.  I used click-once to publish it to a network path.  Then I go to that path from a users pc where I log in as myself (full admin rights) and the install goes fine and I can launch the addin from excel. 

    For some reason however, on another users pc, I do the same thing - log in as myself, install the add-in which goes ok, but then when I try to launch the addin....nothing.  

    What should I check?

    When I view the list of add-ins on the problem pc, its there and enabled.


    • Edited by shiftbit Thursday, September 25, 2014 5:29 PM sdghd
    Thursday, September 25, 2014 5:11 PM

All replies

  • The add-in was installed under your account (per user) and can be used only by that user. You need to log-in as a user who is going to use it and install it. Or create a pre-machine installer and deploy it for all users. In that case all user will be able to run it.

    See Registry Entries for Application-Level Add-Ins for more information. Also you may find the Deploying an Office Solution section in MSDN helpful.

    Thursday, September 25, 2014 5:31 PM
  • Thanks for the quick reply

    On the "problem" pc, Im logged in as myself and trying to run it within Excel, after having installed it successfully. The toolbar button just doesn't do anything.  Its as if something is preventing it from starting.

    Thursday, September 25, 2014 5:47 PM
  • Did you check out the list of COM add-ins in the host application?

    Is your add-in listed as active and loaded?

    Microsoft Office applications can disable add-ins that behave unexpectedly. If an application does not load your add-in, the application might have hard disabled or soft disabled your add-in.

    Hard disabling can occur when an add-in causes the application to close unexpectedly. It might also occur on your development computer if you stop the debugger while the Startup event handler in your add-in is executing.

    Soft disabling can occur when an add-in produces an error that does not cause the application to unexpectedly close. For example, an application might soft disable an add-in if it throws an unhandled exception while the Startup event handler is executing.

    When you re-enable a soft-disabled add-in, the application immediately attempts to load the add-in. If the problem that initially caused the application to soft disable the add-in has not been fixed, the application will soft disable the add-in again.

    You can read more about this in the How to: Re-enable an Add-in That Has Been Disabled article.

    Thursday, September 25, 2014 5:56 PM
  • Yes, as I mentioned above, I made sure the add-in was listed and enabled from options > addins

    Another thing I just tried, is having a user log in under their account on the "good pc" that tested ok earlier, and just simply double-click the manifest.  It worked - the add-in loaded AND ran just like when I was logged in on that pc.

    However, using the manifest on their pc, with them logged in... no go.  Add-in will load, but not run. 

    Where can I check for errors?  I dont see any in the windows event log?

    Windows firewall perhaps?

    Thursday, September 25, 2014 6:44 PM
  • > but not run. 

    Could you please be more specific? What do you mean saying "no run"?

    Did you try to log all add-in operations? For example, you can prepare a debug build for testing and see what's happening under the hood. Does it make sense?

    Thursday, September 25, 2014 6:52 PM
  • When I clicked on the add-in it wouldnt launch or anything.  No errors and the add-in is loaded and enabled.

    Next thing I will try is to put the files in a "trusted" location as mentioned here

    http://office.microsoft.com/en-us/excel-help/add-remove-or-change-a-trusted-location-HA010354311.aspx


    • Edited by shiftbit Friday, September 26, 2014 1:11 AM dfgdfg
    Friday, September 26, 2014 1:10 AM
  • Have you tried using the environment setting VSTO_SUPPRESSDISPLAYALERTS to the environment variables (value 0)? By doing so errors are no longer suppressed.

    Another thing you could try is using ProcDump:

    http://technet.microsoft.com/en-us/sysinternals/dd996900.aspx

    With ProcDump you can see if something is throwing an Exception.

    Maarten


    Software Engineer * MVP-Visual Developer-VSTO

    Monday, October 6, 2014 6:00 PM
    Moderator