none
.Net Framework 4.0 ERROR HELP PLEASE RRS feed

  • Question

  • HELP ME PLEASE
    OS Version = 6.1.7601, Platform 2, Service Pack 1
    OS Description = Windows 7 - x86 Service Pack 1
    CommandLine = E:\1252594d824bc44823f345\\Setup.exe /x86 /x64
    TimeZone = Hora est. Sudamérica Pacífico
    Initial LCID = 3082
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 9
    Exe (E:\1252594d824bc44823f345\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (E:\1252594d824bc44823f345\Windows6.1-KB958488-v6001-x86.msu) failed with 0x240006 - (null).
    Exe (E:\1252594d824bc44823f345\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (E:\1252594d824bc44823f345\netfx_Extended_x86.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20150809_202406467-MSI_netfx_Extended_x86.msi.txt
    Exe (E:\1252594d824bc44823f345\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    MSI (E:\1252594d824bc44823f345\netfx_Extended_x86.msi) Installation failed. Msi Log: Microsoft .NET Framework 4 Setup_20150809_202406467-MSI_netfx_Extended_x86.msi.txt
    Final Result: Installation failed with error code: (0x80070643), "Error irrecuperable durante la instalación. " (Elapsed time: 0 00:00:44).

    Sunday, August 9, 2015 11:25 PM

Answers

  • Your partial log shows only a generic fatal error.

    Please try the install procedure below:

    Follow ALL these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like OneDrive, and post the link here.

    Monday, August 10, 2015 12:03 AM

All replies

  • Hi, i tried a lot of metods to fix this but it's still not working, please help me, i uploaded the logs to paste.bin
    http://pastebin.com/GXpvnjjG
    Sunday, August 9, 2015 10:43 PM
  • Your partial log shows only a generic fatal error.

    Please try the install procedure below:

    Follow ALL these steps exactly:

    Before trying to install .NET Framework 4.0, execute this command from an ELEVATED Command Prompt provided by the .NET Framework Team:

    "This issue is likely caused by a bad ACL on assembly\tmp folder. After installing updates, the ACL propagates to installed assembly folders in both 4.0 & legacy GAC.  If those updates were installed by WU or another user, the propagated ACL will prevent install of the same assembly by the current user.

    A work around would be to reset the ACL on GAC dirs.

    for /F %D in ('dir %WINDIR%\assembly %WINDIR%\Microsoft.NET\assembly /s /b /a:d') do takeown /F %D && icacls %D /reset /T"

    After running that command, follow these steps:

    Please follow these instructions exactly:

    1. Download a fresh copy of the standalone installer for .NET Framework 4.0:

    http://www.microsoft.com/en-us/download/details.aspx?id=17718

    2. Also, clear your %temp% directory and disable your AV software.

    The %temp% directory is a reference to the Temp folder associated with the current user. To clear it, do the following:

    Sign on to your system with the Administrator user account you will use to run the installer. Click the Start Orb and type %temp% in the search box. The search results will show the Temp folder you want. Click on the Temp folder to open it in Windows Explorer, then delete the entire contents.

    3. Run the standalone installer from step 1 As Administrator.

    Note: Just using an administrator account is NOT enough. To activate full privileges, you must right-click the installer, then select Run as administrator.

    If the install fails, provide complete install logs as follows:

    Please collect your install logs with this:

    http://aka.ms/vscollect

    After you run Collect.exe, you'll find vslogs.cab in your %temp% directory. Please upload vslogs.cab to a public site, like OneDrive, and post the link here.

    Monday, August 10, 2015 12:03 AM
  • Duplicate post. Please see replies to your other post on this problem.
    Monday, August 10, 2015 12:08 AM