none
C#/VB Templates not showing in "new project" after reinstall RRS feed

  • Question


  • Around a week and a half ago I reinstalled Visual Studio on my Windows 10 laptop.

    After reinstalling VS2015 once, the IDE launches but the "new project" does not show any of the templates for C# or Visual Basic projects. When I try to open an existing C# project with visual studio, it displays this message -

    "This version of Visual Studio is unable to open the following projects. The project types may not be installed or this version of Visual Studio may not support them."

    Then it opens a migration report, showing the error "The application which this project type is based on was not found." It shows this even for basic C# console applications.

    I've tried repairing/uninstalling/reinstalling Visual Studio 2015 several times, both by web and ISO installers. I've tried using the Total Uninstaller utility before reinstall, and various registry cleaning tools too.

    When I select which packages to install, the installer insists for the "C#/.NET" option that "This component was already found on your system. No action will be taken."

    In all cases the installation finishes with an "installed successfully but some packages were missing or damaged" message. On the last installation (ISO) these included -

    Windows 10 SDK - 10.0.14393
    Installer failed. The hash value was not correct, error - 2146889721

    "Package failed" errors for -

    Visual Studio Connected Services
    Azure AD Authentication Connected Services
    Azure Mobile Services Connected Service
    Azure Storage Connected Service

    I don't even know if these messages are relevant to the same problem.


    Sunday, December 11, 2016 3:36 PM

All replies

  • Hi Arbel,

    Thank you for posting in MSDN forum.

    C# and VB template are installed within VS by default.

    If the error message informs that these basic project type couldn't be found, it means that the VS installer is broken.

    Since you mentioned that you have tried the VS ISO, have you check Its hash-value?

    If not, please use  FCIV to verify the SHA-1 to ensure the ISO is not corrupted.

    Also, if you upgraded to Win 10 recently,  you could check if you have this problem by looking at the vcruntime140.dll file size. Search your windows folder for "vcruntime140" you should see 4 files (64 and 32 bit in both release & debug versions). If any files have the same size, you need to run a repair on the redistributable.

    Refer to:

    Multiple Errors Installing Visual Studio 2015 Community Edition

    If the above still doesn't help, please use  http://aka.ms/vscollect to gather the installation logs. you will find vslogs.zip from %temp% folder. Please upload the file to  Onedrive and share the link here. I will help you find the root cause according to the log file.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, December 12, 2016 7:07 AM
    Moderator
  • I've read the StackOverflow thread in the link. Solutions I've tried over the last few days include:

    Removing all VC++  redistributables from the computer (using IOBit Uninstaller), then deleting the folders mentioned in the thread under user/appdata/local/microsoft, then reinstalling Visual Studio (Web installer, with McAfee LiveSafe's firewall and scanning disabled). Still the exact same problems - errors on installation, error messages on starting Visual Studio that several packages did not load, and no C#/VB templates.

    I also tried enabling symbolic link evaluations under the command prompt with fsutil. I recieved an "Access is denied" error for this, even though I used the "run as administrator" for the command prompt. The same thing happened trying to  delete the installation cache under cd/programdata/package cache.
    Also, I checked the different vcruntime dlls in the windows folder. They all had different sizes, before and after the failed install.
    Then I tried to run repairs on all the new VC++ packages, and repair the VS installation. This didn’t make a difference either.

    Next try – uninstalled Vstudio and the VC++ packages, and deleted the “msvcp140” and “vcruntime140” dlls under the Windows/SysWOW64 and Windows/System folders.
    Then I searched for, and deleted, the following folders under all the “users” folders - VSCommon, VisualStudio, VisualStudioServices, Blend, VsGraphics, ApplicationInsights, vshub, Team Foundation, Web Platform Installer and MsBuild, as well as the entire Microsoft Visual Studio folders under Program Files and Program Files(x86) for 14.0 and all previous versions. Also deleted the Visual Studio and Blend folders under ProgramData/Microsoft, and everything in the AppData/Local/Temp folder.
    Finally, I used File Explorer to delete everything under programdata/packagecache.
    Uninstalled McAfee LiveSafe and IOBit Malware Fighter, I’ll reinstall them after this attempt to install Visual Studio.
    Ran a registry scan/clean with IOBit Advanced SystemCare and restarted the computer.
    Reinstalled Visual Studio using the Web installer. Still got “package failed” errors on installation, and this time no actual Visual Studio executable was installed either.

    Ive collected the installation logs and the link is
    https://1drv.ms/u/s!AgIsz4gG8WePggebUAcH_kJNUCFw
    I've tried most of the solutions in the StackOverflow thread, and I can't try every possible combination of steps to see what gets Visual Studio working.
    It would be great if the installation logs help find the cause, but next I'll probably reset my Windows 10 installation completely as I need VS working.
    Wednesday, December 14, 2016 7:31 PM
  • Hi Arbel,

    Sorry for my delay reply.

    Just from your description, it's indeed frustrated that the above you tried didn't work.

    I agree with you that do a fresh Win 10 installation would save you much time for troubleshooting this, and it will also provide you a much clean environment to install other software and application.

    Looking forward to hear good news from you.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, December 16, 2016 9:46 AM
    Moderator