none
EDI Parsing Problem RRS feed

  • Question

  • Hi,

     

    I am having problems parsing EDI transactions when the unit cost element is 0.10.  For instance in the SamplePO.txt change the first PO1 element from

    PO1*1*93*BX*145.39**CB*KOW-20392-10

    to

    PO1*1*93*BX*0.10**CB*KOW-20392-10

     

    When I try to Validate Instance in Visual Studio I receive the error message:

    error BEC2004: Segment level : Field Error : Segment ID - PO1 : Field Position - 4 : Current value - 0.10 : [ 6 ] Invalid character in data element

     

    If the value is 0.1 the EDI transaction will validate.

     

    Thanks,

    Mike

    Wednesday, April 4, 2007 10:18 PM

Answers

  • Hi Mike, In Beta2 we are supporting a new Party(Party as Sender) property - "Allow leading and trailing zeroes and spaces". Please check it, restart the service and the instance will be parsed successfully as long as it resolves to that Party.

     

    Samit

    Wednesday, April 4, 2007 11:53 PM

All replies

  • Mike - What version of R2 are you using. This problem has been fixed in the Beta2 build.
    Wednesday, April 4, 2007 10:29 PM
  • The version is R2 Beta2.  I downloaded and installed it yesterday.  I'm not sure the dll that is used to validate the schemas otherwise I'd give you the version and build.

     

    Wednesday, April 4, 2007 10:45 PM
  • Hi Mike, In Beta2 we are supporting a new Party(Party as Sender) property - "Allow leading and trailing zeroes and spaces". Please check it, restart the service and the instance will be parsed successfully as long as it resolves to that Party.

     

    Samit

    Wednesday, April 4, 2007 11:53 PM
  • That works for submitting EDI transactions through a receive location.  The Validate Instance in Visual Studio fails.  Probably because the validation doesn't know the party from the ISA and GS segments. 

     

     If the "Allow leading and trailing zeroes and spaces" option was available at validation time in Visual Studio that would be great.

    Thursday, April 5, 2007 3:49 PM