none
WES 7 missing slui.exe RRS feed

  • Question

  • I'm checking out WES 7 on some of our products (we already ship WES 2009), and I'm getting an error:

    "Windows cannot find 'C:\Windows\\system32\\slui.exe'. Make sure you typed the name correctly, and then try again. "

    I get this popup when I click on the activation/change product key links in the system properties window. I built the image using the "Application Compatability" template, but I also searched for "slui.exe" in my distribution share in ICE, but was unable to find the file. Is there an additional feature/component I need to add? Or is this a limitation of the evaluation copy of WES 7? I am using the 180-day trial key that was provided.

    We will be implementing OEM activation if/when we decide to ship WES 7, so this may not have an impact on our image, but it would be interesting to see why the error pops up like this.

    Thanks!

    Thursday, May 13, 2010 1:21 PM

All replies

  • I'm pulling down the RTM toolkits and runtime ISOs from MSDN now so I will see if the slui.exe issue is fixed in them when using the non-evaluation copy Product Key (for the toolkit at least). The runtimes will still run in the 180-day trial until we we order a WES 7 COA/PID.
    Monday, May 17, 2010 6:23 PM
  • Yeah, I built up another "Application Compatability" image using the 32bit toolkit from MSDN with my MSDN-provided 180-day PID, and the slui.exe error is still there.
    Tuesday, May 18, 2010 2:04 PM
  • Hi cgmason,

    This failure and link in the control are related to Windows 7 Activation only and does not impact Windows Embedded Standard 7 activation. The activation and evaluation scheme used by Windows Embedded Standard 7 does not involve the standard ones used by Windows 7, namely through SLUI.exe. You can safely ignore the error.

     

    Thanks

    Shiv - MSFT


    Shivkumar Swaminathan - MSFT
    Wednesday, May 19, 2010 1:03 AM
  • Hi Shiv,

    Thanks for the reply on this. So if I am using the non-evaluation PID for a WES 7 image, this error will go away?

    Chris

    Tuesday, May 25, 2010 5:41 PM
  • Hello Shiv,

    I set up an WES 7 embedded, using a standard template (industrial). A few days later, a power network failure, led to an abrupt shutdown of the new WES 7. After reboot, in the lower right corner of the desktop, a message appeared for the windows build 7600 : This copy of Windows is not Genuine.

    A static key from my MSDN subscription was used during installation, so i though it was ok. But the WES 7 restarted every 20 minutes. I searched for slui.exe, (it was not there), ran checkdisk, sfc /scannow and slmgr.vbs (it was not there).

    I then reinstalled, and now the control panel says there are 37 days available to activate. What will happen then?

    Any idea about this?

    Thank you

    Andreas

    Saturday, July 24, 2010 5:16 PM
  • I'm still seeing this issue.

    Has this been fixed and I'm missing an update? 

    Is there a way to change the product key after installation?

    Thanks.

    Follow up:  Key can be change from command line using "slmgr.vbs /ipk key" command.

    • Proposed as answer by Bounced_1987 Wednesday, December 28, 2011 2:11 PM
    • Unproposed as answer by Bounced_1987 Wednesday, December 28, 2011 2:11 PM
    Monday, August 30, 2010 6:00 PM
  • Hi,

    Try: C:\Windows\System32\slui.exe on a command prompt window.

    Notice that there aren't any \\ in the line.

    Hope this helps.


    Preveen
    Thursday, May 19, 2011 6:54 PM
  • Hi,

    We are starting to ship wes 7 any day now and I can see the same error message in my build.

    I just tried to replace the zero-key with the one I got from Microsoft but the installation fails during specialize! Do I need to add a package for the activation or set any other parameters besides the "ProductKey" in Windows-Shell-Setup pass 4?

    Thanks!

    Tuesday, May 24, 2011 7:26 PM