none
Unable to Login into Storage Explorer

    Question

  • Hello,

    I'm am unable to log into Storage Explorer. I get an "401 - Unauthorized: Access is denied due to invalid credentials". I am a Subscription Admin for my Azure account. I can log into the Azure Portal just fine. Storage Explorer tries to sign in as soon as I enter my e-mail address. The issue started to occur after I changed my Active Directory password. We are using ADFS SSO to login into Azure.

    Side note, I am able to login using a non-SSO *.on.microsoft.com account that's also an Admin.

    - Jon

    Wednesday, February 15, 2017 9:59 PM

All replies

  • Hi Jon,

    Can you try with the following steps then log on again?

    - Close the Storage Explorer if you have it up running?  (in case you are using the attach/SAS connections)

    - Go to your C:\users\username folder, then delete the following cached files:

        .adalcache, .devaccounts, .extaccounts

    - Try to start Storage Explorer and log in again.

    Please let me know if this works.

    Thanks,
    - JingLou @Microsoft/Storage Explorer

    • Proposed as answer by Md Shihab Wednesday, February 22, 2017 4:44 AM
    Thursday, February 16, 2017 1:46 AM
  • Unfortunately no luck. Same error. I also upgraded to the latest version.
    Friday, March 3, 2017 3:46 PM
  • It looks like a cached profile issue

    Try this in your machine, I assume you are using Windows based machine and you have PowerShell installed in this machine

    Get-AzureAccount | ForEach-Object { Remove-AzureAccount $_.ID -Force }

    So what this command does, it twill remove ALL cached profile

    You can run first

    get-azureAccount | format-table id

    And this will show you all cached profiles

    Regards

    Friday, March 3, 2017 5:54 PM