locked
ddproxy sample not working on Vista SP2 x86 RRS feed

  • Question

  • I'm building the ddproxy sample as provided by MS for 32 bit Vista (SP2). The driver installs and runs just fine but does not redirect correctly. For testing purposes I configured it to redirect all DNS traffic from the default DNS IP on my network/system to Google's public DNS server (8.8.8.8). The port remains unchanged 53. Based on the wireshark output and the kernel debugger all outbound packets are intercepted, modified and reinjected correctly but the inbound packets (the DNS responses are visible at the network layer) never make it to the transport or datagramdata layer/callouts in the driver. I also tried it on Win7 x64 with the same result.

    Can anyone confirm that they have the same problem? What might I be doing wrong? What may be gong wrong in the sample or WFP?

    Thanks,

    Michael

    Friday, August 9, 2013 7:22 PM

All replies

  • I see the same thing with ddproxy running on Win7 x86.  Looks like the redirection happens properly but the DNS response times out at the user level - nslookup.
    Monday, August 12, 2013 2:31 PM
  • Were you able to solve this issue? I am having a similar issue, any help would be greatly appreciated.

    thanks.

    Tuesday, December 9, 2014 1:15 AM