none
Problem installing Microsoft .NET Framework 1.1 RRS feed

  • Question

  • Hi i need to install Microsoft .NET Framework 1.1 on my PC for a game i want to play(Lord of the Rings Online), i downloaded the dotnetfx.exe setup file(file version: 1.1.4322.573) and ran it then during the copying new file prosess i got the following error:
    "Error 1304 error writing to file:
    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\shfusres.dll Verify that you have access to that directory."

    So yea im kinda stuck as to what to do, any help with this would be really great.

    Much thanks.
    Friday, February 23, 2007 7:40 PM

Answers

All replies

  • Hello Jonro

    Error 1304 is an error which is given when a file is missing which is required for the instalation.Now in your case , shfusres.dll file is missing, the reason may be due to the corrupted dotnetfx.exe file.This might have been corrupted when downloading, now the better option would be dowload a new file again....but you can try to do this too..

    Download the shfusres.dll file from here

    http://www.dlldll.com/shfusres.dll_download.html

    then after downloding, you will get a zipped file ,extract the dll file and now when the error message pops up, simply paste this shfusres.dll file which we have downloaded into the folder
    c:\windows\microsof.NET\Framework\v1.1.4322\......

    Dont forget to tell me wether it got installed or not...and also tell me if you face any problem with the installation
    Friday, February 23, 2007 9:54 PM
  • Ok thanks for the help  Suryamanoj

    I tryed redownloading the microsof.NET Framework setup file twice again but its still giveing me the error. So i tryed the second option of downloading the dll and here another problem poped up, when i try to extract the shfusres.dll from the zip archive its giveing me this error:

    Extracting to "C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\"
    Use Path: yes   Overlay Files: no
    Error:  The system cannot find the file specified.
    Cannot create C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\shfusres.dll

    Ive also tryed downloading it from different sites and extracting it to different location on my PC but it just gives the same error, ive even tryed useing 2 different extracting programs. I swear my PC hates me lol. Its like my PC just wont accept the shfusres.dll.

    Anyways, thoughts?

    Thanks again for the great help.

    Friday, February 23, 2007 11:34 PM
  • Do one thing, dont extract the file directly into that folder , first of all extract the shufres.dll file onto your desktop or somewhere other than that folder ,and when the installing begins, you manually paste the file into the folder which is created

    I have a doubt, when the installer is saying tat the file is missing, does the error windows have any "RETRY" ,"CANCEL" buttons or only "OK" button?

    If it has RETRY button, then you can do as i said.....wait for the error message to pop up and then manually going and pasting the dll file there and then clicking on RETRY


    IF it doesnt have any retry button, then as soon as the installer begins installing, or more better ,you create the folder too, and then put the dll file and then start the installation, the installer should not have any problems now, tell me what happened
    Saturday, February 24, 2007 6:55 AM
  • And if even the shufres.dll file os not getting extracted on to the desktop too, tell me your email address ,i will mail you the dll file, so that you can do the other things
    Saturday, February 24, 2007 7:02 AM
  • Yea i have tryed to extract it to the desktop and even different drives but i gives me the same error. And yes the install program does have a retry option but still i cant get the damn thing to extract and try it.

    That would be great if you could email me the file, email is: jonrocat2002@yahoo.com.au and if for any reason that dosent work my backup email is jonro@hushmail.com.

    Once again thanks for all the great help.
    Saturday, February 24, 2007 7:39 AM
  • Yes i have sent the file to both of your email addresses..:)

    Now after downloading the file do one thing, First go to the temp folder and delete all of the contents which can be deleted, then also delete the windows\assembly folder, it it doesnt get deleted ,rename it

    Then Create the folder
    C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322\

    and after creating this folder ,paste the dll file into this folder and retry the installation....waiting for your reply

    Have a nice day.and all the best :)

    Saturday, February 24, 2007 8:04 AM
  • I presumed that you know where the temp folder is...Do you know it???
    Saturday, February 24, 2007 8:06 AM
  • What happened???
    Sunday, February 25, 2007 7:20 AM
  • did it work??
    Saturday, March 3, 2007 11:08 AM
  • It sounds like there is some kind of permission problem on this system.  Can you please try the steps listed at http://blogs.msdn.com/astebner/archive/2006/09/04/solving-setup-errors-by-using-the-subinacl-tool-to-repair-file-and-registry-permissions.aspx to reset file and registry permissions and see if that resolves this installation error on your system?

    Thanks!  Aaron

     

    Saturday, March 3, 2007 8:17 PM
    Moderator