none
Discussion Board - categories RRS feed

  • Question

  • Hello,

    I ran into a situation where user created a discussion board with "categories" and they have views created to display the respective categories. So far so good. BUT seems like when a user responds to a discussion (on a flat view[/flat.aspx page]) it does not pick the "category". So when people go to any particular view it shows the discussion and the number of replies (see below). Once you click the discussion to see the replies it's empty. With a bit of digging (editing the reply) I noticed "reply" does not store the Category information - hence being filtered out.

    If I create a new view with out any Filter, replies can be seen. Is this behaviour normal? if so what's the point of creating "categories"? I see people create Categories quite often. Here is an example of adding Categories to a discussion board. 2nd one here.

    Any feedback would be greatly appreciated!  

    


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Thursday, March 31, 2016 6:23 PM

Answers

  • Hi BlueSky,

    I have done a test again in my environment. I could see the same behavior as yours from my SharePoint On-premise and Office365 SharePoint online environment.

    Since the latest Office365 SharePoint online service has the same behavior, I would recommend you submit a feedback about this issue via the below link for your convenience.

    https://sharepoint.uservoice.com/

    It is a place for customers provide feedback about Microsoft SharePoint products. What’s more, if a feedback is high voted there by other customers, it will be promising that Microsoft Product Team will take it into consideration when designing the next version in the future.

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, April 19, 2016 1:31 AM
    Moderator

All replies

  • Hi,

    Are you create discussion board list in SharePoint 2010 or SharePoint 2013?

    How do you add the categories column?

    I have done a test in a SharePoint 2010 and I can't reproduce your issue.

    1. Create a discussion board list and add an existing column named categories.
    2. Create a new view to filter the categories
    3. When navigate to the custom view, once clicking the discussion to see the replies, the replies is displayed. 

    Could you please create a new discussion board and compare the results?

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 1, 2016 10:32 AM
    Moderator
  • Hi Lisa,

    It's in SharePoint 2013 (with June 2014 CU) - sorry I did not mention as I was posting under 2013 thread and thought that would be redundant. :-)

    Anyway the original column was a new choice column added to the list as described in the "example" link I included above. But I tested adding "existing 'Categories' site column" as well - it behaves the same way. Trouble with the Categories column though - it's not a lookup column. 

    Let me know if you have any option to test this out in SP 2013.  

    Any other feedback anyone?

    Many thanks!


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Tuesday, April 5, 2016 2:16 PM
  • Any suggestion anyone?

    I did two further tests one with another 2013 farm (with Aug 2014 CU) and a 2010 farm. It appears to me this is a bug in SharePoint 2013. As in 2013 when users reply to a discussion they don't get an option to choose the category (unlike SP 2010 - as shown below). This is the reason why replies don't show up in the same view when filtered by the categories. 

    Lisa - is there anyway you can report this bug? Let me know if you have any questions. 



    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"


    • Edited by BlueSky2010 Tuesday, April 12, 2016 7:35 PM image re-uploaded
    Friday, April 8, 2016 2:40 PM
  • Any update Lisa?

    Thanks!


    BlueSky2010
    Please help and appreciate others by using forum features: "Propose As Answer", "Vote As Helpful" and "Mark As Answer"

    Monday, April 18, 2016 2:45 PM
  • Hi BlueSky,

    I have done a test again in my environment. I could see the same behavior as yours from my SharePoint On-premise and Office365 SharePoint online environment.

    Since the latest Office365 SharePoint online service has the same behavior, I would recommend you submit a feedback about this issue via the below link for your convenience.

    https://sharepoint.uservoice.com/

    It is a place for customers provide feedback about Microsoft SharePoint products. What’s more, if a feedback is high voted there by other customers, it will be promising that Microsoft Product Team will take it into consideration when designing the next version in the future.

    Best Regards,

    Lisa Chen


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, April 19, 2016 1:31 AM
    Moderator