locked
Cannot debug on 2013. a 64 bit debugging operation is taking longer than expected RRS feed

  • Question

  • Hello,

     I recently installed visual studio 2013 but I cannot debug applications with it. I'm trying to attach to process, but every time I hit the attach to process option. It just gets stuck on an "Operation taking longer than expected" - "a 64 bit debugging operation is taking longer than expected" message. and it doesn't show any process on the attach to process window.

    I'm using VS2013 professional. Before I was using 2012 installed and was having the same problem. but I switched the msvsmon file fore the 32 version, and it was working for 32 bit apps. now I need to work with a 64 and that trick no longer works. I don't know if this might be the cause, but I also have 2010 installed.

    Any ideas what the problem might be? or what should I do to fix this?

    Thank you.

    • Changed type Carl Cai Tuesday, August 5, 2014 8:08 AM
    Monday, August 4, 2014 4:36 PM

Answers

  • Hello,

     I recently installed visual studio 2013 but I cannot debug applications with it. I'm trying to attach to process, but every time I hit the attach to process option. It just gets stuck on an "Operation taking longer than expected" - "a 64 bit debugging operation is taking longer than expected" message. and it doesn't show any process on the attach to process window.

    I'm using VS2013 professional. Before I was using 2012 installed and was having the same problem. but I switched the msvsmon file fore the 32 version, and it was working for 32 bit apps. now I need to work with a 64 and that trick no longer works. I don't know if this might be the cause, but I also have 2010 installed.

    Any ideas what the problem might be? or what should I do to fix this?

    Thank you.

    Hi,

    1. Based on your description, it seems that you have installed VS2010,VS2012 and VS2013 in the same machine, right?

    If so, did you install these Visual Studios with the same way with Installing Visual Studio Versions Side-by-Side

     Install Visual Studio versions in the order in which they were released. For example, install Visual Studio 2012 before you install Visual Studio 2013.

    2. >>I'm using VS2013 professional. Before I was using 2012 installed and was having the same problem. but I switched the msvsmon file fore the 32 version, and it was working for 32 bit apps. now I need to work with a 64 and that trick no longer works.<<

    Did you mean that it has the same issue when you debug 64bit apps with VS2012? You tested it by attaching the process of remote machine, right?

    If you are testing with remote debugging, whether the remote tool matches the version of the Visual Studio which you are using, like Remote Tools for Visual Studio 2013  matched VS2013?

    3. To make sure this issue is not related to the other processes, I would recommend you restart your PC, and close the firewall and the Anti-virus software and the other processes to test.

    4. If that still has this issue, and since VS2012 has the same issue before installed VS2013, I would recommend you uninstall VS2013 and VS2012, then reinstall VS2012 and install updates for VS2012 to test.

    5.If that works fine with #4, then you could reinstall VS2013, and install all updates to test, in addition, Visual Studio 2013 Update 3 (2013.3) RTM is relased, you could install it to test.

    Regards.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Tuesday, August 5, 2014 8:38 AM