locked
Background Service not running RRS feed

  • Question

  • User201048 posted

    Hi, we have implemented a background service used to retrieve new information from our server, when the main application is not running ( killed) This works fine as expected with our development web server (http://54.228.219.43....), informations are updated regularly. But when we use the production server with https://backoffice.xxx.com/yyyy , the service seems not working or at least the informations are not updated. Any ideas ? Thx

    Thursday, October 13, 2016 7:38 AM

All replies

  • User92365 posted

    Hello @HPCAZORLA

    when you tell you have a background service is it a broadcast ?

    have you got any error ? try perhpas to put the ip address of the production server

    tell us more ...

    Thursday, October 13, 2016 8:48 AM
  • User201048 posted

    hi, the background service fetchs new published information and tells the user that he has n new unread informations via a notification message. I've tried using the ip address but it's the same issue.

    Thursday, October 13, 2016 2:51 PM
  • User92365 posted

    Hello @HPCAZORLA

    sorry no idea about your problem, i suppose you have test your application in debug mode with your production server ?

    i'm a beginner with mobile and often when i post a question here not often a reply ... for to find a solution, i create a blank app with just a part on my problem and i try to find a solution with my friend google ...

    is it possible to have some code ?

    have a nice day, for me my day work is finish .. :)

    Thursday, October 13, 2016 3:26 PM
  • User201048 posted

    In fact I could dig into the issue. Its comes from try HttpClient request that returns an exception "System.Net.Webexception" when using https://backoffice.xxxx.com as BaseUrl.

    Saturday, October 15, 2016 2:34 PM