locked
How to disable password request RRS feed

  • Question

  • User1279216868 posted

    I have an IIS web site (which is basicly a PHP based file server) and i want to avoid the authentication procedure.

    At the moment, when i try to connect to the site it asks me for user name and password, but i want that every user (in my LAN) will be able to reach to the site without any authentication.

    What should i do? is it IIS security thing or the problem is in the Windows (Server 2003 BTW...) security?

    Thanks in advance.

     

    Monday, December 3, 2007 2:25 PM

All replies

  • User655220325 posted

    Website properties >> Directory Security Tab >> Edit Button under Authenticaion and access control >> Is "Enable Anonymous Access" checked ?

    Monday, December 3, 2007 3:25 PM
  • User-823196590 posted

    Also make sure that iusr_yourservername has NTFS read permissions on the content files and folders.

    Monday, December 3, 2007 3:52 PM
  • User1279216868 posted

     vijaysk

    "Enable Anonymous Access" is checked.

    tomkmvp

    I gave iusr_yourservername read permissions but still no change...

    Any other ideas?

     Thanks.

     

    Monday, December 3, 2007 4:12 PM
  • User-1853252149 posted

    Is ONLY Enable Anonymous Access checked?

    Jeff

    Monday, December 3, 2007 4:57 PM
  • User1279216868 posted

    No, both Enable Anonymous Access and Integrated Windows Autehntication are checked, but when i remove the V mark from the Integrated Windows Autehntication and trying to connect to the site i receive the following message:

    HTTP Error 401.3 - Unauthorized: Access is denied due to an ACL set on the requested resource

    Tuesday, December 4, 2007 12:38 AM
  • User-1853252149 posted

    Then you are using Windows authentication.  If you truly want anonymous access, and set the ACLs on the folder to allow access by the anonymous user account (normally IUSR_{MachineName}).  If you want the security, add the domain to the intranet zone in IE's securoty tab so IE will pass Windows credentials and you won't be prompted.

    Jeff

    Tuesday, December 4, 2007 8:44 AM
  • User1279216868 posted

    Hi Jeff,

    I want to give full anonymous READ permission to everyone in my LAN (it's not a Domain).

     I gave the IUSR_servername read$execute permissions but still no change - when i try to acees the site it asks me for user name and password.

     Any other ideas?

    Thanks.

    Tuesday, December 4, 2007 12:57 PM
  • User1279216868 posted

    Any other ideas?

     Thanks.

    Saturday, December 8, 2007 5:48 AM
  • User-1853252149 posted

    You want only anonymous access checked and grant the IUSR account READ for the folders/files, as long as you're only using static content (HTML).  If you're using ASP.NET, you will also need to grant access to the ASP.NET process account, which depends on the OS and whether or not you've changed the process account from the defaults.

    Test with a Hello Wolrd HTML file first.

    Jeff

    Saturday, December 8, 2007 7:16 AM
  • User1279216868 posted

    The content of the site is PHP and the OS is Server 2003.

     Is the ASP.NET process still relevant?

    Thanks again...

    <STRIKE></STRIKE>
    Saturday, December 8, 2007 8:02 AM
  • User-823196590 posted

    No.

    Monday, December 10, 2007 8:32 AM
  • User-275064894 posted

    is there a solution to this?  

    I am having this same issue. My 2003 sever is joined server in domain. its not a DC or anything.

    Does the IUSR_compname account need some rights ( logon locally ) from the Security Settings.

     

    Wednesday, January 16, 2008 11:01 AM
  • User-823196590 posted

    Yes, see http://support.microsoft.com/kb/812614

    Wednesday, January 16, 2008 1:13 PM
  • User-638341317 posted

    I am having the exact same problem (on IIS6, Server 03). I have Enable anonymous access checked and when I use the IUSR_servername account I get a 401.3 error. I've enabled the IUSR account to have read access across my entire hard drive (just to make sure) . I've also given the IUSR account full access to the site directories. Still doesn't work. However, when I put my admin account information as the account to use for anonymous access, everything works great. Obviously I can't let my server go live with everyone having admin access, so any sage advice would be appreciated.

    Thanks!

    Wednesday, January 16, 2008 3:58 PM
  • User-638341317 posted

    Wow... nevermind. It was the simplest thing! I forgot to tell my Hello World file that it was allowed to be seen by the IUSR account. For some reason when I enabled IUSR permission for that directory it didn't pass that on to the individual files in it.

    Its those stupid little things that make me waste far to many hours! Grrrrr

    Wednesday, January 16, 2008 4:32 PM
  • User989702501 posted

    Well, in this case, you can always get procmon from microsoft to trace the access error.

    Sunday, January 20, 2008 10:54 PM
  • User-812643437 posted

    I fixed this on diffrent way, 

    Click on VD- Authontication- > Annonymous Authontication -> Right click Edit -> Selcect "Application Pool Identity". ok. 

    All fixed.

    Cheers!

    Sanjay

    Thursday, February 27, 2014 8:18 AM