locked
App deploy not updating component DLL

    Question

  • My application uses a user control DLL that I created in a solution that is separate from the application solution. When I deploy the application to an external device, Surface RT, the user control DLL is not being updated with the latest version. After the deploy the application is the current version but the user control is showing the old interface from when it was initially deployed.  This is not a problem when I run locally or in the simulator.
    Friday, March 29, 2013 6:00 PM

Answers

All replies

  • Have you made sure to rebuild the user control DLL for ARM? If you've just rebuilt it for x86, then the ARM version (and the x64 version) will still be the old version and thus you'll get the old control.

    If that's not it, does the user control DLL have a new version number associated with it?

    Try uninstalling the application from the Surface RT first then deploy it again. It's possible that the "new" DLL and the old have the same version number.


    XNA/DirectX MVP | Website | Blog | @mikebmcl

    Friday, March 29, 2013 8:43 PM
  • Thanks for reply. Yes I've tried everything you mentioned except for the version number change. I'll try that later on today. I was surprised that uninstalling the application on the remote device did not work.
    Friday, March 29, 2013 8:56 PM
  • Well it turns out it was not a deployment problem at all. I was bitten by this:

    http://social.msdn.microsoft.com/Forums/en-US/winappswithcsharp/thread/51111470-8a86-44d4-acb8-e268afa7564e

    I had to add a step in my component solution to copy the needed XAML files to the "proper" directory.

    • Marked as answer by Jesse Jiang Monday, April 1, 2013 2:52 AM
    Saturday, March 30, 2013 12:18 AM