'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine error RRS feed

  • Question

  • Hi<o:p></o:p>

    Host Win 2008 R2 Server (64 bit).<o:p></o:p>

    My app configuration is set to 'Any CPU' in VS2010. I have installed Microsoft Access Database 2010 64 bit. I am using Microsoft.ACE.OLEDB.12.0 as provider. When I run the app I get a The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine error. <o:p></o:p>

    What am I doing wrong and how can I access the MS Access db on 64bit Windows 2008 Server?<o:p></o:p>



    Sunday, June 17, 2012 1:29 AM


All replies

  • Hi<o:p></o:p>

    installed Microsoft Access Database 2010 64 bit. I am using Microsoft.ACE.OLEDB.12.0 a

    ACE.oledb.12.0 dosen't work in the 64-bit os

    download patch from



    • Proposed as answer by s3xs1 Friday, October 4, 2013 4:03 PM
    Sunday, June 17, 2012 11:25 AM
  • Hi

    I have already installed the 64-bit version (AccessDatabaseEngine_x64.exe) of the Microsoft Access Database Engine 2010 from the link you posted. What am I missing? Do I need to install the 32-bit version (AccessDatabaseEngine.exe)? What provider do I need to use?



    • Proposed as answer by Stuart Clowes Monday, June 29, 2020 12:22 PM
    Sunday, June 17, 2012 12:04 PM
  • Hi Yahya,

    Welcome to MSDN Forum.

    Here's a discussion about this error, please refer to it and let me know whether it is worked for you.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine"

    Best Regards

    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    • Proposed as answer by Janos BerkeMVP Monday, June 18, 2012 7:52 AM
    • Marked as answer by Allen_MSDN Monday, June 25, 2012 3:18 AM
    Monday, June 18, 2012 7:36 AM
  • The setup you described appears to be correct. I would verify the install by checking the below path to insure that the data provider exists:

    "C:\Program Files\Common Files\Microsoft Shared\OFFICE14\ACEOLEDB.DLL"

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, June 18, 2012 1:40 PM
  • Hi Yahya,

    Any update about this issue? If you need further help, please feel free to let me know.

    Best Regards

    Allen Li [MSFT]
    MSDN Community Support | Feedback to us

    Thursday, June 21, 2012 2:26 AM
  • Hi

    Check your MS Application if installed as x64 or 32 bit environment. On Web App Server (IIS Manager) try to change your application pool on advance settings >> Enable 32 bit Application - set True/false then restart the application. On windows app try to publish in x86/64 bit.

    Hope it helps

    Best regards

    To better the Man

    • Edited by Frequent J Friday, September 21, 2012 6:10 AM
    Friday, September 21, 2012 6:10 AM
  • This worked fine for me.

    DBA in Pinellas County Schools

    • Proposed as answer by JohnK.NET Saturday, February 2, 2013 3:10 AM
    Thursday, October 11, 2012 1:50 PM
  • Good link!  Perfect fix.  Thanks, Allen.
    Tuesday, November 13, 2012 2:30 AM
  • worked here as well..BUT, had to install both x64 and x86
    Friday, December 21, 2012 5:15 PM
  • The second link worked for me 100%

    Win 7 x64 and Office 2010 x64.

    Wednesday, February 27, 2013 3:03 AM
  • Thanks issue resolved after downolading
    Friday, March 8, 2013 7:48 AM
  • I am still have issues trying to get rid of this error.  The 32 bit does not recognize the .accdb file type.  All my databases are local on my laptop and I am trying to create a connection from my Access database to VBA 2010 express.  Did I miss something in this thread?  I am using Windows 7 home, 64x, VBA express 2010
    Saturday, March 16, 2013 6:28 PM
  • Worked for me Windows Server 2008 R2, SQL Server 2012 (error using import export wizard and Excel files)
    Thursday, April 4, 2013 12:51 PM
  • Sweet, perfect!  This has been driving me bat-crazy, but your solution worked on SQL 2008 R2 64-bit w/ Office 2013 64-bit installed on the same machine.

    Thanks so much!


    • Edited by Bryce White Wednesday, May 1, 2013 2:48 PM edit
    Wednesday, May 1, 2013 2:47 PM
  • Dude u Rock, thanks
    Wednesday, June 5, 2013 5:42 PM
  • This issue is caused by a missing 64-bit installation of the required driver.
    To fix this issue, perform the following steps...

    1.) Install ONLY the 64-bit driver from the following location

    2.) Go to the website's application pool in IIS, choose advanced settings, and set Enable 32-bit applications to FALSE

    3.) Restart the website


    • Proposed as answer by oggynr1 Monday, June 30, 2014 12:04 PM
    Wednesday, June 12, 2013 11:01 AM
  • I am using:

    • Win 7 x64
    • Office 2010(32 bit).
    • MSFT Access Database 2010(32 bit)
    • MSFT Office Access Database engine 2007.

    My project is ANY CPU but still getting this error. Here is my connection string

    "Provider=Microsoft.ACE.OLEDB.12.0;Data Source=" + fileLocation + ";
    Extended Properties=\"Excel 12.0;HDR=Yes;IMEX=1\";"

    And also set the app pool to false for 32 bit. but it is still giving some problem.

    ANy clue?

    Monday, June 17, 2013 9:34 PM
  • If you are working with 32-bit Office then you need to set the Platform option to x86 for Windows apps. If it's a web app then the Enable 32-Bit Applications option should be set to True for the app's application pool.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    • Proposed as answer by Mina Nagy Tuesday, October 29, 2013 1:07 PM
    Monday, June 17, 2013 10:07 PM
  • I am trying to access an Excel (Office-2010 32 Bit) on a WIN-7 machine (64 Bit) using Powershell and receiving this error 'The 'Microsoft.ACE.OLEDB.12.0' provider is not registered on the local machine.'.

    Any help to fix this..

    Wednesday, August 14, 2013 2:30 PM
  • Any solution for the Excel (32-bit) on a Win-7 (64-bit) machine using powershell? Having the exact same problem
    • Proposed as answer by SB54 Sunday, October 4, 2015 7:10 PM
    • Unproposed as answer by SB54 Sunday, October 4, 2015 7:10 PM
    Friday, August 16, 2013 3:57 PM
  • This error usually occurs when there is a mismatch between the bits allocation of the system on which the application  is built and that of the server system it is hosted into.

    If the base system is 32-bits and server is say, 64 bits....This error will erupt.

    To resolve,

    1.) Go to IIS on the server

    2.) Check for the application pool on which the website is hosted.

    3.) Right Click on that application pool and go to properties.

    4.) Set "Enable32-bitsApplication" to true.

    Thursday, August 29, 2013 9:21 AM
  • If you are using a compiled application compile to 32 bit so it matches Office/Access Redistributable.

    Thursday, September 5, 2013 8:21 PM
  • Had the same problem with connecting to MS Access 2013 database from SSDT on x64 and installing the x32 access database engine 2007 solved the problem!
    Thursday, November 21, 2013 2:49 PM
  • I am getting this error, when i adding a reference in the project

    Wednesday, November 27, 2013 3:30 PM
  • Thanks. It works for me~
    Thursday, December 12, 2013 2:31 AM
  • This worked for me.

    I have recently upgraded to office 2013 (64bit) and was trying to import data from Excel to SQL Server 2008 R2. Using the import wizard generated the error you described above. Installing the fix Allen Li posted above worked flawlessly. It even fixed the excel preview issue in Outlook 2013 that I had for excel files.

    Thanks again,

    Ralph Schwehr

    Database Administrator

    State Center Community College District


    Friday, December 20, 2013 5:31 PM
  • I tried running this on a Windows Server 2008 R2 and got the following error:

    Error 1935.  An error occurred during the installation of assembly component {98CB24AD-52FB-DB5F-A01F-C8B3B9A1E18E}.  HRESULT: 0x80070BC9.

    Friday, February 7, 2014 6:51 PM
  • That is the download address, not a patch.


    Tuesday, February 11, 2014 3:53 AM
  • THank You man
    Saturday, February 22, 2014 9:34 AM
  • Hi guys

    I have a similar one but a little more complicated.

    Two servers, one is a virtual directory of the first one. Both need to access OLEDB12. The driver is installed on the 1st machine, 64bit. How to make it available on the 2nd machine?

    Tuesday, July 1, 2014 12:04 PM
  • Install it...


    Tuesday, July 1, 2014 1:34 PM
  • Yes.. It works!!

    I have SQL Server 2012 64 bit, MS Office 64 bit and Win 7 64 Bit.  When I tried to import an Excel File created in 32 bit I got this error.


    Download and install this 32 bit Access Database Engine


    I tried to install first the 64bit Access engine did nor work, from 


    The solution is 32 bit engine from the:



    Wednesday, July 9, 2014 4:46 PM
  • I ve installed it but no such dll in this file path what should I do now?
    Friday, July 11, 2014 11:31 AM
  • Try to add new build configration in to your project: Like this
    Thursday, July 24, 2014 3:25 PM
  • Allen Li wrote:

    Hi Yahya,

    Welcome to MSDN Forum.

    Here's a discussion about this error, please refer to it and let me know whether it is worked for you.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine

    Hi Allen,

    I reviewed that link but it states that it works only for 64 bit Office installations.

    I am running 32-bit Office (on 64 bit Windows 7), and I am attempting to connect to Access 2010 through VBScript (vs a web-app).  Do you know of a solution that will work for me?  Thanks!

    [EDIT]:  I found an alternate method which is working for me, which is to run my VBScript via 32-bit cscript.exe  ref: stackoverflow.com/questions/2806584/how-do-i-run-a-vbscript-in-32-bit-mode-on-a-64-bit-machine

    However, I would still be interested in knowing if there is a solution that is more closely related to the 64-bit Office method that Allen provided.  Thanks again!

    • Edited by SkiReturn14 Friday, August 15, 2014 7:42 PM
    Friday, August 15, 2014 6:13 PM
  • Or you could do like we did and uninstall 32 bit and install 64 bit Office. Less problems overall esp. when build .NET CPU=ANY apps which doesn't really work well with the ACE provider.


    Friday, August 15, 2014 8:49 PM
  • it helps me a lot....
    Monday, August 18, 2014 8:04 AM
  • Have tried all the above but still get

    The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine

    running windows 8.1 with sp1 x64

    can someone please advise how you register it.

    Monday, September 8, 2014 3:02 AM
  • Even when using the Server Explorer in Visual Studio to connect to an Access Database you get the message

    The ‘Microsoft.ACE.OLEDB.12.0’ provider is not registered on the local machine

    Monday, September 8, 2014 3:09 AM
  • Visual Studio (Server Explorer) runs 32-bit so you would need to have the 32-bit version of the ACE OLEDB Provider installed.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Monday, September 8, 2014 3:34 AM
  • Changing the Application Pool worked for me.  Thanks!
    Monday, November 24, 2014 10:41 PM
  • It actually helped. Thanks :)
    Saturday, December 13, 2014 3:42 PM
  • Same problem here

    Basically Office 64 bit will not install with any 32 bit version of Office on it.

    The database engine for 32 bit get's removed even if it is needed by other applications that seem to only use the 32 bit call. So you have re-install the 32 database engine after Office 64 bit is installed.

    Even 64 bit version of SQL server 2012 seems to only recognize the 32 bit database engine, why I do not know.

    Microsoft needs to correct this rather glaring issue with SQL Server

    Tuesday, January 13, 2015 4:59 PM
  • works for me after installing "2007 Office System Driver: Data Connectivity Components". Thanks!!!
    Thursday, February 12, 2015 7:29 PM
  • Hi,

    I have similar issue when we are reading Excel file.

    History of the problem:

    We recently migrated our application from 32-bit to 64-bit because of the memory requirement. For that we migrated our windows 7 from 32-bit to 64-bit. But still we installed 32-bit office on our machines.

    because, of this we had this issue while importing Excel data into application.


    I downloaded 64-bit version of the http://www.microsoft.com/en-us/download/details.aspx?id=13255 and installed with argument as,

    AccessDatabaseEngine_x64.exe /passive

    Without any code change my issue get resolved.


    On 64-bit OS and 64-bit office, my functionality was working fine without this fix. This fix is only required while our application is 64-bit running on 64-bit OS which is having 32-bit office installed on it.

    Thanks, Rahul Techie.

    Friday, February 13, 2015 8:57 AM
  • I would be somewhat cautious here when installing both the 32-bit and 64-bit Access Database Engine when 32-bit Office is installed. I installed the 64-bit version and immediately some features in 32-bit Microsoft Outlook (such as adding a new folder) stopped functioning. After uninstalling the 64-bit version it worked fine again.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Friday, February 13, 2015 2:52 PM
  • Hi Paul,

    When I communicated with Microsoft for this, even they are not in favor of such type of solution.

    But, after applying this solution, I didn't face any kind of such issue.

    Still, I am replacing my office from 32-bit to 64-bit.

    Thanks, Rahul Techie.

    Monday, February 16, 2015 6:58 AM
  • wow, this finally worked for me,

    i have 64 bit OS, but 32 bit office product...

    AccessDatabaseEngine_x64.exe /passive

    Thanks mate

    Thursday, May 14, 2015 3:12 PM
  • Now, you also need to make sure that you are compiling to 64 bits. you can check that in the project properties, under debugging.
    Saturday, June 6, 2015 3:32 AM
  • thanks.. it worked

    Ravikiran. S

    Thursday, August 27, 2015 3:35 PM
    Friday, September 18, 2015 2:55 PM
  • If you use the 32 bit version of Powershell, it works out of the box.
    On my Windows 8.1 box, I found the 32 bit version here:


    Sunday, October 4, 2015 7:13 PM
  • The download recommended on the thread you refer to worked for me.

    The original Access 2010 Redistributable worked fine on my laptop: Windows-10 32-Bit, Office 2016, VS 2010

    However, I needed the 2007 Office System Driver: Data Connectivity Components for my Desktop running Windows-10 64-Bit, Office 2016, VS 2010. Why?? Don't ask me!

    Thanks very much.

    Sunday, December 6, 2015 1:04 PM

  • I have created a Console Application, its running fine on my system but throws error on other systems with Ace.Oledb.12.0 is not registered. 

    I have installed the patches from above link with no success. Am I missing anything?

    I also ran the below script in Powershell to check if oledb.12 is there in system or not, and it shows no entry for oledb.12 or oledb.10.

    (New-Object system.data.oledb.oledbenumerator).GetElements() | select SOURCES_NAME, SOURCES_DESCRIPTION 

    Please help!

    Wednesday, January 20, 2016 8:15 AM
  • Please ask a new question in the forum.

    Paul ~~~~ Microsoft MVP (Visual Basic)

    Wednesday, January 20, 2016 2:28 PM
  • Sure Paul. Thanks 

    Wednesday, January 20, 2016 3:12 PM
  • I had Microsoft Access Database Engine 2010 Redistributable already installed on my machine but was still receiving the Microsoft ACE OLEDB Provider error. 

    Then I recalled that I had upgraded to Office 2016 recently, so, may be I should try reinstalling Microsoft Access Database Engine 2010 Redistributable. And that fixed the problem on my machine. 

    So, if you have upgraded to different version of MS Office or even repaired/reinstalled your MS Office then try reinstalling Microsoft Access Database Engine 2010 Redistributable before wasting time with finding other fixes. Good luck!
    Monday, April 18, 2016 6:42 PM
  • This worked for me. Thanks a lot.
    Thursday, August 25, 2016 4:36 PM
  • Hi Allen,

    Is there any workaround which will not require me to uninstall my present version of MS Office and Install and a different version altogether.

    Monday, October 17, 2016 10:23 AM
  • I have had this error many times, as I run 64-bit Office and SSMS 2012, which does not seem to include a 64-bit Import/Export Wizard bundle by default (that's a whole other issue!).

    When you have 64-bit Office, you don't have the 32-bit ODBC drivers for Excel (fe.), which SSMS 32 (fe.) depends upon. Installing the 32-bit AccessDatabaseEngine.exe installs those ODBC drivers and resolves.

    If running 32-bit Office with a 64-bit app that relies on 64-bit ODBC Excel drivers (fe.), same issue occurs, and installing AccessDatabaseEngine_x64.exe resolves.

    I only posted this, because there is no clear explanation of this simple and straight forward issue anywhere on the internet! ... and if I forget, maybe Google can actually help now ;)

    • Edited by _DHV_ Thursday, December 1, 2016 5:34 PM
    • Proposed as answer by _DHV_ Thursday, December 1, 2016 5:38 PM
    Thursday, December 1, 2016 5:32 PM
  • Good morning

    Thank you for these posts. I followed the links

    For me it's a conflict with 64bit OS's (Win7 is mine) and 32bit Office.

    I uninstalled 32bit office and installed 64bit office still same problem. I installed AccessDatabaseEngine_X64.exe from microsoft.com/en-us/download/details.aspx?id=13255

    And it works now

    Hope this helps.

    Sincerely, Wesley

    Tuesday, April 18, 2017 3:38 PM
  • Thank you. this really help me.
    Tuesday, April 18, 2017 9:38 PM
  • Thanks. This helped!
    Wednesday, July 5, 2017 2:52 PM
  • It works for me with

    Microsoft Access Database Engine 2007

    • Edited by vbdear Tuesday, August 22, 2017 1:53 PM
    Tuesday, August 22, 2017 1:50 PM
  • Thank you!!!!!
    Wednesday, December 6, 2017 10:58 PM
  • This link worked for me! The second link inside:


    Tuesday, January 30, 2018 10:10 PM
  • This link worked for me! The second link inside:


    That link no longer works.

    VB .NET Developer

    Friday, September 13, 2019 4:28 PM
  • Microsoft Access Database 2010 64 bit Worked for me After I  have installed Microsoft Access Runtime 64- bit Application .


    Thursday, September 19, 2019 1:14 PM
  • Hi Allen,

    I'm having the same issue. Microsoft.ACE.OLEDB.12.0 provider is not registered on the local machine.

    I'm using Windows 10 64-bit, Office 365 ProPlus 64-bit, Access Database Engine.

    As searched for the solution i found this link.

    HOW TO: FIX ERROR - "the 'microsoft.ace.oledb.12.0' provider is not registered on the local machine"

    When i went into this link, it was mentioned to go through the second link in that page, and the link is


    And in this, it is mentioned as This download is no longer available.

    I request you kindly provide the solution.



    Monday, October 21, 2019 4:43 PM
  • Thanks, works for me
    Tuesday, March 3, 2020 1:20 PM
  • Try this out instead.  Microsoft Access Database 2010 64 bit cleared the error for me.  Follow the installation steps in the link below.


    Thursday, June 4, 2020 10:33 PM
  • https://docs.google.com/document/d/15GTXgazw_OiRJE4L02Ur9fgYsM7QqNDkAxHfsM2A1VU/edit
    Wednesday, September 9, 2020 6:14 PM