locked
ClickOnce url parameters not passed through from IE in metro

    Question

  • Hi. I have a ClickOnce app that requires the parameters passed in the Url. When I launch the app from IE in the Metro view, my ClickOnce app launches but the parameters are lost. It seems that it's being downloaded and launched from a temp directory because the Security Warning dialog from Click Once shows the "From" text as being a local folder instead of the domain it actually came from.

    If I launch the Click Once from IE on the desktop then the parameters are passed through fine.

    Is that a bug or is that behaviour designed?

    Thanks.

    Myles


    Myles Jeffery | Office365 MVP | Thinkscape | SharePoint Online File Migration Tool
    Wednesday, September 28, 2011 11:06 PM

All replies

  • Thank you for posting your feedback, we want to make sure we get the right info including your log files. Can you also submit feedback using the Windows Feedback Tool from the Connect Site associated with your Windows Developer Preview program? If you’re an MSDN subscriber, the information on how to join the Connect program is included on the download page where you installed Windows Developer Preview. There’s a link to the Connect site and an invitation code that you can click on to join using a Windows Live ID account. If you’re not an MSDN subscriber follow this limited use link to join the Connect program and then follow the steps here.

    If you are prompted for an invitation code, please enter the following key. MSDN-76H9-3CFP

    https://connect.microsoft.com/site1147/InvitationUse.aspx?ProgramID=7221&InvitationID=MSDN-76H9-3CFP


    Marilyn
    Wednesday, October 5, 2011 1:20 AM
    Moderator