locked
EDI Batching disable validation RRS feed

  • Question

  • Hi,

    I'm using BizTalk 2009 to batch outgoing EDI messages.
    In my party settings I have configured the batch and the EDIFACT settings to get the prefered output.

    I can get the batch to work if my data is valid for the EDI schema.
    But in a specific case, I want to disable the validation because the end party wants something that is not 100% valid. :)

    So I changed my party settings to disable the EDI Type validation. But the orchestration still validates the messages.
    If I send the same message through the EDI Send Pipeline it's no problem.
    How can I disable the validation in the EDI Batching Orchestration? The documentation states that all messages will be validated.

    Kind Regards
    Tim D'haeyer


    Tim D'haeyer - MCTS BizTalk Server Blog : http://blog.codit.eu
    Thursday, November 17, 2011 6:58 AM

All replies

  • As far as I am aware of, we cannot disable the validation when working with the out-of-the-box batching EDI orchestrations.

    Work-arounds will depend on what kind of validation errors you are experiencing. Is it structual, encoding or are you assigning invalid values in the EDI segments?

    Morten la Cour

    Thursday, November 17, 2011 7:53 AM
  • For now I only need to allow leading and trailing spaces. But I can't even get that to work. :-(
    We can also have the case that we need to send an EDIFACT without UNA but with '.' (dot) as the decimal character.
    The only way to do that is to disable the EDI Type validation.


    Tim D'haeyer - MCTS BizTalk Server Blog : http://blog.codit.eu
    Thursday, November 17, 2011 7:57 AM
  • Have you tried disabling validation under Transaction Set Settings->Validation under "EDIFACT Fallback Settings"? I guess since the batching orchestration clearly doesn't use its own agreement setting it could be using the fallback settings?

    Morten la Cour

    Friday, November 25, 2011 2:24 PM
  • Hi Morten,

    Changing the EDIFACT Fallback Settings doesn't really have an effect.
    At first we could still find a workaround for this by changing the data in the mapping.

    But now it is really causing problems. Should we resort to writing our own Batching Service?

    Kind Regards
    Tim D'haeyer


    Tim D'haeyer - MCTS BizTalk Server Blog : http://blog.codit.eu
    Tuesday, December 13, 2011 10:17 AM