locked
Continuing thread from codeproject.com

    Question

  • Hi Jonathan, as I was saying, I'm new to Pex, what I didn't find in your article is the real start from scratch.
    What I did was follow exactly what your article said, install Pex and start a new project (VS 2008 WinForms) adding the method mentioned there.
    I didn't see the "Run Pex Explorations" item in the context menu strip, after right clicking the code.
    After that I added a reference to "Microsoft.Pex.Framework" on the project and still nothing.
    So what am I missing? Or do I have an installation problem?

    Thanks for yor help.

    Regards,
    Fábio

    "To alcohol! The cause of and solution to all of life's problems." - Homer Simpson
    Tuesday, January 13, 2009 10:54 AM

Answers

  • Ok, got it working, reinstalling it did the trick. Not sure what went wrong in the first time.

    Regards,
    Fábio

    "To alcohol! The cause of and solution to all of life's problems." - Homer Simpson
    • Marked as answer by Fábio Franco Tuesday, January 13, 2009 6:18 PM
    Tuesday, January 13, 2009 6:18 PM

All replies

  • Hi Fabio,

    • Did you create a C# Winform project? If you created a VB.NET project, it won't work.
    • You should remove the Microsoft.Pex.Framework.dll reference: Pex detects if it has to run in 'digger' mode by detecting if the project references Microsoft.Pex.Framework or not.

    It may be an installation problem. Another thing to try:

    • on the project node, try right click -> Run Pex Explorations.
    • on the project node again, try right click -> Pex -> Create Parameterized Unit Test Stubs.
    • pop up the Pex views: Views -> Other Windows -> Pex Exploration Results/Pex Suggestions

    Tell me if none of them worked...


    Jonathan de Halleux
    Tuesday, January 13, 2009 4:12 PM
    Owner
  • Hi Jonathan, yes I was running a C# WinForms app. Anyway I started out a new projet just to check and still no go. All I could see was the VS's "Create Unit Test..." item. The other options you suggested also no good.

    Do you know of any compatibility issues with AnkhSVN?

    I'm not sure what is the problem so I think I will uninstall it and install it again.

    Thanks again for your help, I will post here soon to check if I can get it working. While that if you have any suggestions I'd appreciate it.

    Regards,
    Fábio



    "To alcohol! The cause of and solution to all of life's problems." - Homer Simpson
    Tuesday, January 13, 2009 4:52 PM
  • Also, there is no Pex sub-category on the context menu strip of the project node or the Pex View Windows.

    I guess this is a bad install...

    "To alcohol! The cause of and solution to all of life's problems." - Homer Simpson
    Tuesday, January 13, 2009 4:55 PM
  • Ok, got it working, reinstalling it did the trick. Not sure what went wrong in the first time.

    Regards,
    Fábio

    "To alcohol! The cause of and solution to all of life's problems." - Homer Simpson
    • Marked as answer by Fábio Franco Tuesday, January 13, 2009 6:18 PM
    Tuesday, January 13, 2009 6:18 PM