locked
Event 2262,IIS-W3SVC-WP followed by Event 5013 WAS RRS feed

  • Question

  • User457746146 posted
    </xml><![endif]--><!--[if gte mso 9]><xml> <o:shapelayout v:ext="edit"> <o:idmap v:ext="edit" data="1"/> </o:shapelayout></xml><![endif]--> <body lang=EN-US style='tab-interval:.5in'>

    System:<o:p></o:p>

    Server 2008 x64 SP2<o:p></o:p>

    Exchange 2007 SP2<o:p></o:p>

    fully updated and patched<o:p></o:p>

    8 Exchange Clients, 4 iphone clients<o:p></o:p>

    <o:p> </o:p>

    Symtoms:<o:p></o:p>

    The system runs fine, we don't notice anything at the end user level, but looking inside the logs we see these two interrelated issues.<o:p></o:p>

    <o:p> </o:p>

    Attempt to resolve:<o:p></o:p>

    http://support.microsoft.com/default.aspx?scid=kb;en-us;821268<o:p></o:p>

    http://technet.microsoft.com/en-us/library/cc735024(WS.10).aspx<o:p></o:p>

    The lack of a simplified/unified solution to this issue has prevented me from resolving it.  With MSFT changing the GUI, Files, and more from version to version on its MMC's it has left those of us looking to resolve this issue - unresolved.<o:p></o:p>

    I have read the standard support pages on this issue but they seem to focus on fixing the machine.config files and in looking at this file on our server, that file does not contain any of the settings that.  Why does MSFT make it so hard to find the solutions to issues?<o:p></o:p>

    <o:p> </o:p>

    Copy of Event ID:<o:p></o:p>

    Log Name:      Application<o:p></o:p>

    Source:        Microsoft-Windows-IIS-W3SVC-WP<o:p></o:p>

    Date:          11/29/2009 11:41:11 AM<o:p></o:p>

    Event ID:      2262<o:p></o:p>

    Task Category: None<o:p></o:p>

    Level:         Warning<o:p></o:p>

    Keywords:      Classic<o:p></o:p>

    User:          N/A<o:p></o:p>

    Computer:      MARS.globalstyletrading.com<o:p></o:p>

    Description:<o:p></o:p>

    ISAPI 'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll' reported itself as unhealthy for the following reason: 'Deadlock detected'.<o:p></o:p>

    Event Xml:<o:p></o:p>

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"><o:p></o:p>

      <System><o:p></o:p>

        <Provider Name="Microsoft-Windows-IIS-W3SVC-WP" Guid="{670080D9-742A-4187-8D16-41143D1290BD}" EventSourceName="W3SVC-WP" /><o:p></o:p>

        <EventID Qualifiers="32768">2262</EventID><o:p></o:p>

        <Version>0</Version><o:p></o:p>

        <Level>3</Level><o:p></o:p>

        <Task>0</Task><o:p></o:p>

        <Opcode>0</Opcode><o:p></o:p>

        <Keywords>0x80000000000000</Keywords><o:p></o:p>

        <TimeCreated SystemTime="2009-11-29T04:41:11.000Z" /><o:p></o:p>

        <EventRecordID>65476</EventRecordID><o:p></o:p>

        <Correlation /><o:p></o:p>

        <Execution ProcessID="0" ThreadID="0" /><o:p></o:p>

        <Channel>Application</Channel><o:p></o:p>

        <Computer>MARS.globalstyletrading.com</Computer><o:p></o:p>

        <Security /><o:p></o:p>

      </System><o:p></o:p>

      <EventData><o:p></o:p>

        <Data Name="IsapiExtension">C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll</Data><o:p></o:p>

        <Data Name="UnhealthyReason">Deadlock detected</Data><o:p></o:p>

        <Binary><o:p></o:p>

        </Binary><o:p></o:p>

      </EventData><o:p></o:p>

    </Event><o:p></o:p>

    ---------------------------------------------------------<o:p></o:p>

    <o:p> </o:p>

    Log Name:      System<o:p></o:p>

    Source:        Microsoft-Windows-WAS<o:p></o:p>

    Date:          11/29/2009 11:43:00 AM<o:p></o:p>

    Event ID:      5013<o:p></o:p>

    Task Category: None<o:p></o:p>

    Level:         Warning<o:p></o:p>

    Keywords:      Classic<o:p></o:p>

    User:          N/A<o:p></o:p>

    Computer:      MARS.globalstyletrading.com<o:p></o:p>

    Description:<o:p></o:p>

    A process serving application pool 'MSExchangeSyncAppPool' exceeded time limits during shut down. The process id was '2940'.<o:p></o:p>

    Event Xml:<o:p></o:p>

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event"><o:p></o:p>

      <System><o:p></o:p>

        <Provider Name="Microsoft-Windows-WAS" Guid="{524B5D04-133C-4A62-8362-64E8EDB9CE40}" EventSourceName="WAS" /><o:p></o:p>

        <EventID Qualifiers="32768">5013</EventID><o:p></o:p>

        <Version>0</Version><o:p></o:p>

        <Level>3</Level><o:p></o:p>

        <Task>0</Task><o:p></o:p>

        <Opcode>0</Opcode><o:p></o:p>

        <Keywords>0x80000000000000</Keywords><o:p></o:p>

        <TimeCreated SystemTime="2009-11-29T04:43:00.000Z" /><o:p></o:p>

        <EventRecordID>108032</EventRecordID><o:p></o:p>

        <Correlation /><o:p></o:p>

        <Execution ProcessID="0" ThreadID="0" /><o:p></o:p>

        <Channel>System</Channel><o:p></o:p>

        <Computer>MARS.globalstyletrading.com</Computer><o:p></o:p>

        <Security /><o:p></o:p>

      </System><o:p></o:p>

      <EventData><o:p></o:p>

        <Data Name="AppPoolID">MSExchangeSyncAppPool</Data><o:p></o:p>

        <Data Name="ProcessID">2940</Data><o:p></o:p>

        <Binary><o:p></o:p>

        </Binary><o:p></o:p>

      </EventData><o:p></o:p>

    </Event>

    Sunday, November 29, 2009 1:00 AM

Answers

  • User2054361436 posted

    I also experienced this problem with a very similar setup to G8trsRule.

    Server 2008 x64 SP2 and Exchange 2007 SP2.

    The same event logs were showing on our Hub Transport/Client Access server. We have quite a few Activesync clients. The server is running on Vmware ESXi.

    I added a second CPU to the VM and the problem appears to have been fixed. Now been running for 3 days without the two listed events appearing. Before they were appearing around 4-6 times in a 24 hour period.

    I assume that the <processModel autoconfig="true"/> is now basing allowed requests etc on the 2 CPUs now rather than one. If you can't stick another CPU in your machine then the changes to machine.config Leo suggested are presumably the best bet. That was certainly what I was going to try next.

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, December 7, 2009 5:40 AM
  • User-273802438 posted

    Hi we experienced similar issues and found that some settings related to client certificates were the cause, feel free to check out my blog post on this issue:

     Microsoft Server Activesync, Iphone and client certificates issues

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, November 17, 2010 12:32 PM

All replies

  • User744767459 posted

    Hi, 

    I have read the standard support pages on this issue but they seem to focus on fixing the machine.config files and in looking at this file on our server, that file does not contain any of the settings that. 

    By default, there is a <processModel autoConfig="true"/> element in machine.config file , you can replace this element with the recommended configuration settings in the KB article.

    The <httpruntime/> and <connectionManagement/> elements not present in machine.config file by default. You can add <httpruntime/> element in the <<system.web> section group, add the <system.net><connectionManagement/></system.net> element in the <configuration> section group.

    Tuesday, December 1, 2009 10:54 PM
  • User457746146 posted
    Hi, Thank you for taking the time to help. You see, your answer only points me in a vague direction. You see, there are multiple machine.config files to confuse the situation and they are written in a very messy and hard to edit. Since the deadlock is coming from: ISAPI 'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\aspnet_isapi.dll' reported itself as unhealthy for the following reason: 'Deadlock detected'. I presume the machine.config file I want to adjust is located in: 'C:\Windows\Microsoft.NET\Framework64\v2.0.50727\CONFIG\ It is easy to find the <processModel autoConfig="true"/> element but what to replace it with is not 100% clear and in what format. So in this section, how would you replace it for a quad core processor without hyperthreading? <system.web> <processModel autoConfig="true"/> The other fix is totally a mystery to me...<<system.web> (while there are many <system.web>) does not exist in my machine.config file. you can't assume we understand what you understand, altho it would be nice to read your mind. We need a clear and concise step by step resolution. Your help is appreciated. A complete copy of my machine.config file is located here: http://dl.dropbox.com/u/362040/machine.zip You can email me the file at thaidrez AT hotmail If you could make the appropriate changes and highlight them or bold them so I could see what you are talking about...that would be greatly appreciated. Thank you. Thank you
    Tuesday, December 1, 2009 11:33 PM
  • User2054361436 posted

    I also experienced this problem with a very similar setup to G8trsRule.

    Server 2008 x64 SP2 and Exchange 2007 SP2.

    The same event logs were showing on our Hub Transport/Client Access server. We have quite a few Activesync clients. The server is running on Vmware ESXi.

    I added a second CPU to the VM and the problem appears to have been fixed. Now been running for 3 days without the two listed events appearing. Before they were appearing around 4-6 times in a 24 hour period.

    I assume that the <processModel autoconfig="true"/> is now basing allowed requests etc on the 2 CPUs now rather than one. If you can't stick another CPU in your machine then the changes to machine.config Leo suggested are presumably the best bet. That was certainly what I was going to try next.

     

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, December 7, 2009 5:40 AM
  • User-273802438 posted

    Hi we experienced similar issues and found that some settings related to client certificates were the cause, feel free to check out my blog post on this issue:

     Microsoft Server Activesync, Iphone and client certificates issues

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, November 17, 2010 12:32 PM