devenv command line "/Command" option & MyMacros


  • Hi,


    I'm trying to issue a command line build for a VS project and need to run a macro "MyProcedure" as follows :-


    If I remove the "/command" option from the batch file then everything works just fine, however as soon as I add this back in I get an error as follows: -

    "The operation could not be completed"


    I have tried several different macros now and get the same problem every time. I've tried explicitly calling "devenv.com" and "devenv.exe" and both display the same behaviour. I never get any clues about "Why" this failure happens, to me this lack of verbose reporting is insane.


    I've set the VS2005 build options for "MSBuild project build output verbosity:" to "Diagnostic"... Yet still no more clues ! A simple "Couldn't find the macro" or "Error in macro" or something would help but "The operation could not be completed" is simply useless.


    Do we have a fix for this ?... What am I missing ?...


    I've seen a few posts now that say its an intermittent error and some that say they've never got it to work. IMHO its not much use having a "/command" option if it doesn't work...


    Please help.



    Monday, September 03, 2007 9:06 AM

All replies