none
VS 2015 crash on project load

    Question

  • I have a problem with my VS2015. Last week it started crashing when loading any project. I finally uninstalled / reinstalled. Then it worked until today. Now it is doing the same. Crash when loading any project.

    From the event viewer I see this exception. Any idea what is causing this ?

    (sorry, I'm pasting the entire stack and its very long).

    Edit - removed most of the stack as.

    Thanks

    Application: devenv.exe
    Framework Version: v4.0.30319
    Description: The application requested process termination through System.Environment.FailFast(string message).
    Message: Microsoft.VisualStudio.Composition.CompositionFailedException: Import "Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider" could not be satisfied. ---> Microsoft.VisualStudio.Composition.CompositionFailedException: Value exported from "Microsoft.VisualStudio.ComponentModelHost.VsComponentModelHostExporter.Provider" cannot be assigned to import site "Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider".
       at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.ThrowIfExportedValueIsNotAssignableToImport(RuntimeImport import, RuntimeExport export, Object exportedValue)
       at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.GetValueForImportSite(RuntimePartLifecycleTracker importingPartTracker, RuntimeImport import)
       at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()
       --- End of inner exception stack trace ---
       at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()
       at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.SatisfyImmediateImports()
       at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveNext(PartLifecycleState nextState)
       at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)
       at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToStateTransitively(PartLifecycleState requiredState, HashSet`1 visitedNodes)
       at 

    ...

       at System.Windows.Threading.ExceptionWrapper.InternalRealCall(System.Delegate, System.Object, Int32)
       at System.Windows.Threading.ExceptionWrapper.TryCatchWhen(System.Object, System.Delegate, System.Object, Int32, System.Delegate)
       at System.Windows.Threading.Dispatcher.LegacyInvokeImpl(System.Windows.Threading.DispatcherPriority, System.TimeSpan, System.Delegate, System.Object, Int32)
       at MS.Win32.HwndSubclass.SubclassWndProc(IntPtr, Int32, IntPtr, IntPtr)


    • Edited by jkristia Monday, April 18, 2016 11:39 PM
    Monday, April 18, 2016 11:37 PM

Answers

All replies

  • Hi jkristia,

    According to another thread that you posted on StackOverFlow, you have resolved your problem by "uninstalled all plugins and extensions. Then re-installed only TS".

    http://stackoverflow.com/questions/36706018/vs-2015-crashes-when-loading-project

    Based on the solution, the problem mostly caused by the plugins and extensions for Visual Studio. I suggest you uninstall these plugin and extensions one by one to confirm which one causes Visual Studio crashes.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.


    Wednesday, April 20, 2016 5:21 AM
    Moderator
  • I'm having the same issue, and I followed the same process:

    1. Removed all extensions (though I really need them)
    2. Uninstalled VS2015
    3. Reinstalled VS2015

    Everything worked fine and the problem went away.  Today, when the project was reloading after fetching from Git, VS2015 crashed.  When it restarted itself, I got the error again.

    This is very frustrating.  I don't believe it's the extensions, especially because after I added them back post-reinstall, I had no issues.  I've been able to work without problems for over a week now.  Today, no extensions changed, nothing was updated, and the problem has returned.

    Here is the entry with stack trace from the Activity Log:

    <entry>
        <record>469</record>
        <time>2016/05/23 18:59:06.167</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>SetSite failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage][Import &quot;Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider&quot; could not be satisfied.]:{   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.SatisfyImmediateImports()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveNext(PartLifecycleState nextState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToStateTransitively(PartLifecycleState requiredState, HashSet`1 visitedNodes)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToStateTransitively(PartLifecycleState requiredState, HashSet`1 visitedNodes)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveNext(PartLifecycleState nextState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.GetValueReadyToExpose()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass53_0.&lt;CreateExport&gt;b__0()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass70_0`2.&lt;GetExports&gt;b__1()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.GetExportedValue[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.GetService[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.MakeLanguageServiceContentTypes(SettingsStore settingsStore)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorPackage.Initialize()&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)}[Value exported from &quot;Microsoft.VisualStudio.ComponentModelHost.VsComponentModelHostExporter.Provider&quot; cannot be assigned to import site &quot;Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider&quot;.]:{   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.ThrowIfExportedValueIsNotAssignableToImport(RuntimeImport import, RuntimeExport export, Object exportedValue)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.GetValueForImportSite(RuntimePartLifecycleTracker importingPartTracker, RuntimeImport import)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()}</description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
        <hr>80131500</hr>
        <errorinfo>Import "Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider" could not be satisfied.</errorinfo>
      </entry>

    Please help.  I seriously cannot burn several hours uninstalling and reinstalling every few days just to work.

    Thanks

    Monday, May 23, 2016 7:09 PM
  • I am also experiencing the same issue. I suspect something has changed with VS or a Windows Update.<description>Begin package load [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]</description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
      </entry>
      <entry>
        <record>572</record>
        <time>2016/05/24 18:48:17.700</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>SetSite failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage][Import &quot;Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider&quot; could not be satisfied.]:{   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.SatisfyImmediateImports()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveNext(PartLifecycleState nextState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToStateTransitively(PartLifecycleState requiredState, HashSet`1 visitedNodes)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToStateTransitively(PartLifecycleState requiredState, HashSet`1 visitedNodes)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveNext(PartLifecycleState nextState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.GetValueReadyToExpose()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass53_0.&lt;CreateExport&gt;b__0()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass70_0`2.&lt;GetExports&gt;b__1()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.GetExportedValue[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.GetService[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.MakeLanguageServiceContentTypes(SettingsStore settingsStore)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.TextDocData.SetSite(Object pUnkSite)&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.GetValueReadyToExpose()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass53_0.&lt;CreateExport&gt;b__0()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass70_0`2.&lt;GetExports&gt;b__1()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.GetExportedValue[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.GetService[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.MakeLanguageServiceContentTypes(SettingsStore settingsStore)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorPackage.Initialize()&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)}[Value exported from &quot;Microsoft.VisualStudio.ComponentModelHost.VsComponentModelHostExporter.Provider&quot; cannot be assigned to import site &quot;Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider&quot;.]:{   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.ThrowIfExportedValueIsNotAssignableToImport(RuntimeImport import, RuntimeExport export, Object exportedValue)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.GetValueForImportSite(RuntimePartLifecycleTracker importingPartTracker, RuntimeImport import)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()}</description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
        <hr>80131500</hr>
        <errorinfo>Import "Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider" could not be satisfied.</errorinfo>
      </entry>
      <entry>
        <record>573</record>
        <time>2016/05/24 18:48:17.717</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>End package load [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]</description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
        <hr>80131500</hr>
        <errorinfo>Unspecified error
    </errorinfo>
      </entry>
    </activity>

    Tuesday, May 24, 2016 6:54 PM
  • I have the same problem. It worked fine when I left work Monday, now I get this (below) and nothing shows up in the Solution View when I open a project. I just spent a couple of hours uninstalling and reinstalling VS 2015 last week due to a different problem, so this is impacting my productivity negatively.

    <entry>
        <record>501</record>
        <time>2016/05/25 14:06:18.015</time>
        <type>Information</type>
        <source>VisualStudio</source>
        <description>Begin package load [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]</description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
      </entry>
      <entry>
        <record>502</record>
        <time>2016/05/25 14:06:18.158</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>SetSite failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage][Import &quot;Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider&quot; could not be satisfied.]:{   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.SatisfyImmediateImports()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveNext(PartLifecycleState nextState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToStateTransitively(PartLifecycleState requiredState, HashSet`1 visitedNodes)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToStateTransitively(PartLifecycleState requiredState, HashSet`1 visitedNodes)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveNext(PartLifecycleState nextState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.GetValueReadyToExpose()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass53_0.&lt;CreateExport&gt;b__0()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass70_0`2.&lt;GetExports&gt;b__1()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.GetExportedValue[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.GetService[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.MakeLanguageServiceContentTypes(SettingsStore settingsStore)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.TextDocData.SetSite(Object pUnkSite)&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.MoveToState(PartLifecycleState requiredState)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.PartLifecycleTracker.GetValueReadyToExpose()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass53_0.&lt;CreateExport&gt;b__0()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.&lt;&gt;c__DisplayClass70_0`2.&lt;GetExports&gt;b__1()&#x000D;&#x000A;   at System.Lazy`1.CreateValue()&#x000D;&#x000A;   at System.Lazy`1.LazyInitValue()&#x000D;&#x000A;   at System.Lazy`1.get_Value()&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.ExportProvider.GetExportedValue[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.GetService[T]()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService()&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.MakeLanguageServiceContentTypes(SettingsStore settingsStore)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider)&#x000D;&#x000A;   at Microsoft.VisualStudio.Editor.Implementation.EditorPackage.Initialize()&#x000D;&#x000A;   at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)}[Value exported from &quot;Microsoft.VisualStudio.ComponentModelHost.VsComponentModelHostExporter.Provider&quot; cannot be assigned to import site &quot;Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider&quot;.]:{   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.ThrowIfExportedValueIsNotAssignableToImport(RuntimeImport import, RuntimeExport export, Object exportedValue)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.GetValueForImportSite(RuntimePartLifecycleTracker importingPartTracker, RuntimeImport import)&#x000D;&#x000A;   at Microsoft.VisualStudio.Composition.RuntimeExportProviderFactory.RuntimeExportProvider.RuntimePartLifecycleTracker.SatisfyImports()}</description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
        <hr>80131500</hr>
        <errorinfo>Import "Microsoft.VisualStudio.Editor.Implementation.LegacyContentTypeSource.GlobalServiceProvider" could not be satisfied.</errorinfo>
      </entry>
      <entry>
        <record>503</record>
        <time>2016/05/25 14:06:18.243</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>End package load [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]</description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
        <hr>80131500</hr>
        <errorinfo>Unspecified error
    </errorinfo>
      </entry>


    FreshBaked

    Wednesday, May 25, 2016 2:17 PM
  • I agree with Maurice in that it does not seem to be an extensions issue.  I have found that my VS 2015 instance on my computer with Windows 7 enterprise has not yet had the issue while my Windows 10 computer might as well be a doorstop at this point except for the fact that Visual Studio 15 Preview and Visual Studio Code work fine.

    Maurice, have you solved the problem yet.  All of my colleagues are now using other editors.

     
    Saturday, June 18, 2016 7:52 PM