locked
ExtensionlessUrlHandler-Integrated-4.0" has a bad module RRS feed

  • Question

  • User-1740395346 posted
    I am working with the new webAPI with .net c# and iis7.5 on a windows7 machine. When I do a Get and POST everything works as expected, but when i do a PUT or DELETE I keep getting errors. I've added accept VERBS of PUT,DELETE to ExtensionlessUrlHandler-Integrated-4.0" and I get a 500 Internal server error, when I remove PUT,DELETE from ExtensionlessUrlHandler-Integrated-4.0" has a bad module I get a response of 404 not found. Can someone please help me with this before I loose my mind? I've worked on this for two days and cannot resolve this. I have the trace file open if I can get any information to someone to help with this. 66. -MODULE_SET_RESPONSE_ERROR_STATUS ModuleName IIS Web Core Notification 128 HttpStatus 500 HttpReason Internal Server Error HttpSubStatus 21 ErrorCode 2147942413 ConfigExceptionInfo Notification EXECUTE_REQUEST_HANDLER ErrorCode The data is invalid. (0x8007000d) Warning 67. -SET_RESPONSE_ERROR_DESCRIPTION ErrorDescription Handler "ExtensionlessUrlHandler-Integrated-4.0" has a bad module "ManagedPipelineHandler" in its module list
    Friday, July 20, 2012 5:00 PM

Answers

  • User-176674611 posted

    Have you tried re-register asp.net via aspnet_regiis.exe? 500.21 is module not recognized, so this should not happen if the module is correctly registered.

    Thanks.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, July 25, 2012 3:52 AM

All replies

  • User-176674611 posted

    Have you tried re-register asp.net via aspnet_regiis.exe? 500.21 is module not recognized, so this should not happen if the module is correctly registered.

    Thanks.

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Wednesday, July 25, 2012 3:52 AM
  • User-1115514305 posted

    Worked for me.

    Monday, January 28, 2013 11:11 PM