locked
Problems while setting a new web site application under IIS 7 RRS feed

  • Question

  • User646581547 posted

    Hello all,

     I'm going to tell you what's happening.

    SYSTEM

     

    - Windows Vista Home Premium

    - IIS 7 

     

    1. Firstly I created a new directory in the system;

    2. Secondly I created a new web site under IIS 7;

    •   I left their default configurations such as:
      • Application Poll: DefaultAppPool
      • so on;

    3. I got this error

     

    HTTP Error 500.0 - Internal Server Error

    Description: This application is running in an application pool that uses the Integrated .NET mode. This is the preferred mode for running ASP.NET applications on the current and future version of IIS.

    In this mode, the application using client impersonation configured with <identity impersonate="true" /> may not behave correctly. Client impersonation is not available in early ASP.NET request processing stages and may lead modules in those stages to execute with process identity instead. You have the following options:

    1) Disable client impersonation.

    If your application design allows it, you can disable client impersonation by setting <identity impersonate="false" /> in your web.config file. This will make your application code execute with the process identity.

    NOTE: This option may require permissions on your application's files and data to be changed to allow access to the process identity.\

    2) Disable this error.

    If you do not have any modules executing within the BeginRequest and AuthenticateRequest ASP.NET pipeline stages, or it is acceptable for that code to execute under process identity, you can disable this error by setting <validation validateIntegratedModeConfiguration="false" /> in your application's configuration. Do this only after making sure that the rest of your configuration is compatible with Integrated .NET mode, as thiswill turn off the runtime validation for the application.

    3) Move this application to an application pool using the Classic .NET mode (PREFERRED).

    You can move the application to an application pool that uses the Classic .NET mode by using the following from a command line window (the window must be running as Administrator)

    %systemroot%\system32\inetsrv\APPCMD.EXE set app "v2.oalexandrino.com/" /applicationPool:"Classic .NET AppPool"

    Alternatively, you can use any other application pool on your system that is running in the Classic .NET mode. You can also use the IIS Administration tool to move this application to another application pool.

    ............................

    ............................

    ............................ 

     "

    4 - I changed  "Application Poll" to "Classic .NET AppPool"

    • the previous issue has gone now! But.........
    • I GOT this:

    HTTP Error 401.2 - Unauthorized

    Description: You are not authorized to view this page due to invalid authentication headers.

    Error Code: 0x80070005

    Notification: AuthenticateRequest

    Module: IIS Web Core

    Requested URL: http://localhost:80/

     

    5. on the "AUTHENTICATION TAB"

    I have just 3 options:

    they are:

     

    1. Anonynous authentication;
    2. ASP.NET impersonation;
    3. Forms authentication;

    I can't see windows Integrated authentication as I had at IIS 6 on my Windows 2003 server.

     

    Thanks a lot!

     

     

    Tuesday, July 31, 2007 2:30 PM

All replies

  • User209782248 posted

    oalexandrino,

    Your application can probably work in Integrated mode using option #2, assuming that you dont have any custom modules that require to be impersonated prior to the authentication stage (most applications dont).  But, to be safe, you could move back to Classic mode as you did.

    As I mentioned on another thread, Windows Authentication is not available in Windows Home Premium: Where is Windows Authentication??.  This is unfortunate but is the case.  Windows Authentication is available starting with Windows Vista Professional.

    I believe on another thread you mentioned that you succesfully moved your application from using Windows Authentication.

    Thanks,


    Mike Volodarsky

    Program Manager
    IIS Core Server
    Visit mvolo.com for more inside information on IIS7, IIS and ASP.NET

    Tuesday, August 7, 2007 1:53 PM
  • User1531821102 posted

    dear friend,

    just forget everything, the application pool and that appcmd and everything

    just undo all the changes as if you have freshly installed iis 7.0 so that you don't get those cheap http 500 and 401 and 402 errors

    just check that your IUSR_machine name is given full control under the security tab of your database folder. and if not just give it the permssion

     

    after you get pro you should see error as

    an error occured while processing the url  ......

    Ok, so I suspected that the first problem was due to the fact that I needed to activate asp scripts in some way. However, turns out it was a new setting for sending the error message to the client . This setting is located in the new IIS Manager:

    Features View, ASP, Debugging Properties, Send Errors to Browser

    just checked this out and then

    i got the following error

    Microsoft JET Database Engine error ‘80004005′
    Unspecified error
    /myapp/myscript.asp, line 9

    actually this is the permission problem with the temp folder (not c:\temp)

    vista uses a different location here it is given

     C:\Windows\ServiceProfiles\NetworkService\AppData\Local\Temp

    just change the permission for the folder

    IUSR_your machine name

    give full control

     

    and your problem wil be solved

    guaranteedly...!!!!

    good day

    Thursday, March 20, 2008 11:12 AM
  • User1968831643 posted

    I'm sure you figured this out, but this is the first time I ran into this problem and I didn't find the answer posted anywhere so I thought I would post it here. 

    For some reason when creating a new site (or even on the default site) there is an authorization rule set on the site root automatically that denies anonymous access.  Since all web applications have to access the web.config on the root, this effectively makes anonymous access impossible on the underlying web applications.  Remove this authorization rule from the root of the site and the rest of the applications should then work properly without having to use Windows Authentication.

     

    Wednesday, July 1, 2009 1:03 PM
  • User-1160259987 posted

    Hi bailey,

    I am facing the same issue & not sure how to  remove the authorization rule from the root site. Could be please help!!!!!!!!!!!!

     

    Thanks!!!

     

    Friday, January 28, 2011 2:17 AM
  • User-1672167363 posted

    Hello,

    If you open the web.config in the root directory

    you will find in the nested collection

    of settings that there will be

    section marked as

    <authorization> The elements in here are how the authorization is set

    <authorization>

    Check or change the configuration with appcmd.exe.

     Martin

    Saturday, January 29, 2011 5:10 PM